I have a 2000 Mustang V6 3.8. Sometimes when I am driving it will loss power(electrical) power like the batt. has came disconnected. But it is only for a split sec or two and come right back on. Also sometimes after driving it, I will got to get start it up and the car has no power at all. Its like the batt. I have no power what so ever. And I will trun the key off and wait bout 5 or so mins and try to start it again and will have power and start right up. But while waiting for it I will jiggle the batt cables, I habe replaced all the batt cables pos. and neg. and I am still having the same problem. Does any one have any ideas please??.


Asked by Sep 05, 2013 at 10:30 AM

Question type: Maintenance & Repair

I have a 2000 Mustang 3.8 V6. I am having the problem of when I am driving the car will loose power completely as in electrical power, everything shuts of. But it is only for a second or two. Also after driving, I will get back into the car to start it and the car will not have any power to it at all. But after waiting 5 mins. or so it car will have power and crank right up. I will also jiggle the batt wires around while waiting, I have replaced both pos. and neg. batt cables and I am still having the problem. Any have any ideas please

1 Answer

Tom Demyan

Can you jiggle the battery cables and other wires when the car is running to see if you can get it to turn off? Maybe you have a ground that is corroded or rusted?

Your Answer

Add photo

Related Questions

  • 77 dodge powerwagon still waiting for answers to post 9 answers

    Rough idle cuts out or off. Misses. Have donever timing chain.coil. Starter. Starter relay found the short in in the wire that made it not start. Ballistor. Coil spark plugs now has residue of carbo...

    1977 Dodge Power Wagon


    Maintenance & Repair

  • loss of power while driving 127 answers

    today, while driving, the vehicle simply lost all power and had to be immediately pulled over. after a few minutes tried to start the vehicle and it worked fine. driving conditions were cold and wet...

    2010 Ford Edge Limited


    Maintenance & Repair

  • Engine power loss and sputtering 43 answers

    It seems like I have a loss of power when accelerating and driving around 50-60 mph at ~2k rpm. The car also sputters and rpm begins to fluctuate while driving. Is the fuel injector bad or clogged and...

    1995 Pontiac Grand Prix 2 Dr SE Coupe


    Maintenance & Repair

  • Starts and dies 44 answers

    Why would my sons 2001 Grand Am start for a second and then die? I disconnected the negative side of battery and waited about 10 mins. Reconnected battery and it started. Ran for 4-5 mins, shut it off...

    2001 Pontiac Grand Am SE


    Maintenance & Repair


Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 145,740
#2 FordNut
Reputation 100,740
#3 dandyoun
Reputation 82,390
View All