I just bought a 1995 eagel talon with a eclipse 2.0 L motor. When I start it it runs bad. Blowing white smoke. No overheating. Air sucking in oil cap when removed. Hesitates to get up and go.Need Help

Asked by Aug 29, 2013 at 12:34 AM

Question type: Maintenance & Repair

1995 eagel talon with either a 1994-
1997 eclipse 2.0L motor is what the
guy told me.

8 Answers

65

maybe when they put the eclipse engine in the eagle talon they did not hook up everything right i would take it to the mitshibushi dealer to see what they say i used to have a eagle talon it had a exhaust leak so i got rid of it

I'd look at the ambient air sensor or IAT (intake air temp)...this one tells the computer how rich to make the mix based on the outside temperature...combined with the data from the engine temperature sensor can get the combustion right~!

Could it be my valve seals?

this business is in effect the "choke"...but there ain't no choke....so there's this...bunch of sensors and a computer....valves ain't got nuttin' to do with it~

So what do I need to do

sensor 21.95~

engine temperature sensor ---round 30 bucks~

no one seems to be "mark helpful" for the added reputation...guess that HUGE number on my left means nothing to you~....what do I have to gain by suggesting that you get a new nose and new ears for your computer~....sheesh some people, I tell ya~

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    186,270
  • #2
    dandyoun
    Reputation
    97,290
  • #3
    tennisshoes
    Reputation
    82,510
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.