77 f 150 I still dont know what the issue is truck running nextthing it does not turn on.. Battery good cables good altrrnator good i think... Started when a wire by radio stated burning.. ???any other solutions ...

Asked by May 25, 2013 at 12:30 AM

Question type: Maintenance & Repair

What can i do this is frustrating?? Do i just take it to the
mechanic ???

2 Answers

254,705

I would if you don't know where to start looking for the problem. Electrical issues are a bear to deal with. Since you had a wire burning, you have a short somewhere under the dash. You might have to remove the dash to find the problem and know how to probe the connections and have a wiring diagram. I suggest you take it to a professional to diagnose it.

70,365

If this is an aftermarket radio double check all the electrical hook ups. Check your fuses as well. All of them. For a wire to get hot enough to burn you either have a bad short or bad overload on that wire or circuit. Actually a fuse should have blown BEFORE the wire started burning. Make sure your fuses are all the correct amperage for the circuit they are plugged into. NEVER ever put a fuse of a higher amperage into a circuit. If the correct amp fuse blows you have a problem and the fuse blows to prevent a fire. HTH. -Jim

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    179,940
  • #2
    dandyoun
    Reputation
    95,400
  • #3
    tennisshoes
    Reputation
    78,700
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.