2009 Ford Escape Loss of Power

Asked by May 24, 2013 at 09:19 PM

Question type: Maintenance & Repair

I have 76K miles on my '09 Ford Escape w/a V6 4WD engine, and while driving on the freeway, it suddenly lost power and I had to pull off on the shoulder, as the accelerator was not powering the engine.  The 'maintenance needed' light was lite, and the engine was sputtering.
I turned it off, and then back on, and seemed to reset itself, and ran fine for about 1/2 hr when it happened again.  After getting it going again, I was able to drive it home 125 miles w/no further problems.
I'm assuming this is some sort of computer problem developing, but wondering if anyone else has experienced this, and potentially what the fix is...

Thanks for any advise/suggestion you can offer...
Rich

2 Answers

233,065

I would scan the computer for fault codes, and see if something is stored in memory. It could be a throttle postion sensor starting to fail. I'd have it looked at by a compentent mechanic, I wouldn't want to be stuck on the side myself.

1 out of 1 people think this is helpful.
Best Answer
50

Did you ever figure out the problem? I have the same problem with our 2009 4 cylinder and there are no engine codes to check when it starts back up. My mechanic and I are stumped. I replaced all the spark plugs and valve cover gasket too. Thanks, Brandon

2 out of 2 people think this is helpful.

Your Answer

Add photo

Related Questions

  • Temporary quick power loss 2006 escape 1 answer

    While driving on freeway at 60 mph My escape had a quick power loss but then continued to run. No warning indicator light came on, could there be an electrical short? Sometimes my CD player blank...

    2006 Ford Escape XLT

    -

    Maintenance & Repair

  • Loss of Power 2 answers

    I was driving my escape today and noticed that it started to knock a little. As I continued to drive the check engine light came on and then there was a noticeable loss of power. When I got home I n...

    2006 Ford Escape XLT

    -

    Maintenance & Repair

  • escape power loss 2 answers

    The car starts fine but after 3-4 minutes driving it starts to bog down until it almost stalls. temp guage is only in the middle. Changed thermistat didn't fix any ideas?

    2002 Ford Escape XLS 4WD

    -

    Maintenance & Repair

  • 2010 FORD ESCAPE FANS RUNNING CONSTANTLY 200 answers

    I have a 2010 Ford Escape. Recently the Air Conditioning control went out and would not work on setting 1. At the same time the 2 radiator fans under the hood started running constantly and very loud....

    2010 Ford Escape XLT

    -

    Maintenance & Repair

  • where can i engaged 4*4 on the 2009 ford escape 1 answer

    i can locate the 4*4 in the ford escape

    2009 Ford Escape Limited 4WD

    -

    General

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 166,090
#2 dandyoun
dandyoun
Reputation 90,560
#3 tenspeed
tenspeed
Reputation 73,340
View All