2009 Ford Escape Loss of Power

Asked by May 24, 2013 at 09:19 PM

Question type: Maintenance & Repair

I have 76K miles on my '09 Ford Escape w/a V6 4WD engine, and while driving on the freeway, it suddenly lost power and I had to pull off on the shoulder, as the accelerator was not powering the engine.  The 'maintenance needed' light was lite, and the engine was sputtering.
I turned it off, and then back on, and seemed to reset itself, and ran fine for about 1/2 hr when it happened again.  After getting it going again, I was able to drive it home 125 miles w/no further problems.
I'm assuming this is some sort of computer problem developing, but wondering if anyone else has experienced this, and potentially what the fix is...

Thanks for any advise/suggestion you can offer...
Rich

2 Answers

247,335

I would scan the computer for fault codes, and see if something is stored in memory. It could be a throttle postion sensor starting to fail. I'd have it looked at by a compentent mechanic, I wouldn't want to be stuck on the side myself.

2 of 2 people found this helpful.
Best Answer
50

Did you ever figure out the problem? I have the same problem with our 2009 4 cylinder and there are no engine codes to check when it starts back up. My mechanic and I are stumped. I replaced all the spark plugs and valve cover gasket too. Thanks, Brandon

2 of 2 people found this helpful.

Your Answer

Add photo

Related Questions

  • 2009 Ford Escape Loss of Power 2 answers

    I have 76K miles on my '09 Ford Escape w/a V6 4WD engine, and while driving on the freeway, it suddenly lost power and I had to pull off on the shoulder, as the accelerator was not powering the engine...

    Maintenance & Repair

  • Loss of power 4 answers

    Hey guys, ive got a 1997 volvo s40 t4 and im noticing some loss of power, i was wondering if it was more likely to be a problem with the turbo or the fuel pump?

    1997 Volvo S40

    -

    Maintenance & Repair

  • 89 ford f150 loss of power 3 answers

    I have a 89 ford f150 fuel injected 351 engine. I was driving and all of a sudden it lost power. Will hardly stay running at an idle. It doesnt rev up as it should. Its a 4 speed manuel and when f...

    1989 Ford F-150 S Standard Cab 4WD LB

    -

    Maintenance & Repair

  • Loss of engine power 2 answers

    I changed my air filter and my 2009 gmc. Shortly after check engine light came on as well as loss or engine power. I changed it back but I still have the same problem.what did I do wrong?

    2009 GMC Sierra 1500 SLE Ext. Cab LB

    -

    Maintenance & Repair

  • Sudden loss of power 2 answers

    Sudden loss of power won't go over 10-12 mph. Starts normal, idle ok, no unusual sounds. Takes off normal, just no power.

    1994 Geo Prizm 4 Dr LSi Sedan

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 175,170
#2 dandyoun
dandyoun
Reputation 93,670
#3 tennisshoes
tennisshoes
Reputation 76,190
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.