2000 Seville sts 4.6 I checked plug,wire they look good seem to have no vac leaks car runs really rough when first started and smoothes out when I rev it up once its warm you hardly notice rough idle nothing when driving still geting missfire code on #7 cyl any thoughts on a bad or clogged injector I really don't want to spend 200 bucks on a hunch that I might have a bad coil any thoughts thanks

10

Asked by May 03, 2013 at 01:04 AM

Question type: Maintenance & Repair

1 Answer

90,025

Try some fuel system cleaner. It could be the EGR valve.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

  • rough idle, stalling, loss of power. 225 answers

    o2 sensor code 44 (lean) Replaced: coolant temp sensor, tps, map sensor, fuel filter, and o2 sensor. It will run normal on occasion but only lasts about 45 seconds or so. I don't think its the torqu...

    1995 GMC Sierra 1500 K1500 SL 4WD Extended Cab Stepside SB

    -

    Maintenance & Repair

  • rough idle 24 answers

    I have a rough idle, which doesn't seem to affect acceleration (yet), but it is annoying as heck. No codes are thrown.

    1999 Infiniti Q45 4 Dr Touring Sedan

    -

    Maintenance & Repair

  • Rough Running 22 answers

    ok so i have my 91 nissan 300zx turbo with 100,000 miles on it and im a nissan tech so i should be able to figure this out but im sumped anyways, so im wondering if anyone has any ideas? ok so my car ...

    1991 Nissan 300ZX 2 Dr Turbo Hatchback

    -

    Maintenance & Repair

  • Idling rough 12 answers

    I took my car to that mechanic three times after he "worked" on it (he did rear main seal, timing belt, water pump, plugs, wires, distributor cap, valve cover gasket). And every time I went back, th...

    1992 Toyota Celica ST Coupe

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,460
#2 FordNut
FordNut
Reputation 103,300
#3 dandyoun
dandyoun
Reputation 84,290
View All