I Have a 96 dodge ram 1500 ran fine, shut it off at store one day, came out would crank but not fire, replaced fuel pump, has fuel at relief valve, replaced spark plugs, cap and rotor, doesn't have voltage at 2 wire plug going into coil. what is going on? Apparently this engine does this to a lot of people and the answers seem to go from one extreme to another, but no has said that any of them work.

5

Asked by Mar 30, 2013 at 08:16 PM

Question type: Maintenance & Repair

5 Answers

How does it sound when you crank it? Like valves are opening on time? Does the distributor still turn (if equipped) am suspecting a broken timing chain, just keep tryin' to see if it sounds totally normal, like it's tryin' or it is out to lunch...~

it it doesn't cough...let's see maybe NO SPARK might be the case and timing gear is a false alarm~

distributor should turn round and round (if equipped).~ if it ain't turnin' goodbye engine.

3,955

have you checked all the fuses?

3,220

Could be worn out or dirty ignition switch. Feed the coil 12v with a small jumper, if it runs then it will really narrow it down as far as trouble shooting goes.

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 174,840
#2 dandyoun
dandyoun
Reputation 93,520
#3 tennisshoes
tennisshoes
Reputation 76,070
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.