have a 79 F 150 with 300 seems to run while starter is turning, getting fuel and fire,but wont continue to run.

Asked by Mar 07, 2013 at 09:13 AM

Question type: Maintenance & Repair

8 Answers

19,545

make sure the coil is getting voltage with the key in the RUN position. I'm sure you have but manipulate the throttle to try to keep it going.

1 of 1 people found this helpful.
Best Answer Mark helpful

took a little longer to quit, little rusty that might be it.

19,545

it may need idled up, or better yet the choke may not be working. Did this happen suddenly or has the truck been sitting for some time and your trying to revive it?

happened suddenly , seem to run fine the day before oil presser was a little low other than that no problems.

19,545

its an old motor, as long as oil pressure isnt 0 it should be good. Id pour a little gas down its neck to see if that helps. Play with ignition advance, play with the choke. Make sure no vacuum hoses came off, cold engine+vacuum leak = no running

yea could have missed one , ill do that ,thanks

closer look, found leak in intake manifold, still replace coil and dis cap wont hurt.

19,545

she had a vacuum leak, that'll do it

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    182,070
  • #2
    dandyoun
    Reputation
    96,170
  • #3
    tennisshoes
    Reputation
    79,990
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.