Won't start again after warming up and partial cool down.

30

Asked by Jul 16, 2013 at 10:25 AM about the Dodge Omni

Question type: Maintenance & Repair

Won't start again short time after warming up.

I turn the key to "on" and the check engine lamp comes on. After 30 seconds it blinks 10 times and stays on. When I turn the key to start, it starts and the malfunction light goes out and stays out. After the car warms up and I stop the engine and then after 1/2 hr or so it cranks ok but won't start. If I let it sit for a couple hrs it starts ok. No fault codes show any time . what's going on?

1 Answer

30

needed crankshaft position sensor.

3 of 3 people found this helpful.

Your Answer

Dodge Omni Experts

  • #1
    TheCanadian007
    Reputation
    150
  • #2
    Chris McGee
    Reputation
    40
  • #3
    msmsls
    Reputation
    30
View All

Related Models For Sale

Used Mazda MX-5 Miata
67 Great Deals out of 4,296 listings starting at $1,900
Used BMW M5
21 Great Deals out of 615 listings starting at $9,500
Used Dodge Challenger
278 Great Deals out of 21,942 listings starting at $6,900
Used Dodge Neon SRT-4
40 listings starting at $5,990
Used Dodge Charger
418 Great Deals out of 27,419 listings starting at $2,495
Used Honda Civic
800 Great Deals out of 72,083 listings starting at $1,400
Used Volkswagen GTI
133 Great Deals out of 8,440 listings starting at $2,400
Used BMW M3
41 Great Deals out of 1,718 listings starting at $5,995
Used Chevrolet Camaro
384 Great Deals out of 30,498 listings starting at $3,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.