my 04 blazer defrost quit working. Does not appear to be the fuses. Please help

Asked by Sep 07, 2012 at 07:27 AM about the Chevrolet S-10 Blazer

Question type: Maintenance & Repair

My 04 blazer defroster quit working.  Does not appear to be fuse-related.  Please help.

1 Answer

7,935

Check the connections at the rear hatch glass, the tab my have broken off. I'm assuming you are talking about the rear defroster?

Your Answer

Chevrolet S-10 Blazer Experts

  • #1
    carGrrl
    Reputation
    1,530
  • #2
    Cody Doud
    Reputation
    650
  • #3
    emtfirefighter77
    Reputation
    370
View All

Related Models For Sale

Used Chevrolet S-10
6 Great Deals out of 1,207 listings starting at $2,500
Used Chevrolet Blazer
3 Great Deals out of 1,061 listings starting at $950
Used Chevrolet Silverado 1500
2,074 Great Deals out of 165,791 listings starting at $1,900
Used Chevrolet Colorado
270 Great Deals out of 31,366 listings starting at $1,995
Used Chevrolet TrailBlazer
90 Great Deals out of 4,570 listings starting at $1,475
Used Chevrolet Tahoe
674 Great Deals out of 39,457 listings starting at $1,000
Used Ford Ranger
188 Great Deals out of 5,537 listings starting at $1,499
Used Chevrolet Camaro
403 Great Deals out of 30,674 listings starting at $3,550
Used Ford Mustang
675 Great Deals out of 37,799 listings starting at $895
Used Chevrolet Monte Carlo
12 Great Deals out of 1,304 listings starting at $2,500
Used Chevrolet Impala
514 Great Deals out of 34,056 listings starting at $950
Used Dodge Dart
245 Great Deals out of 8,215 listings starting at $3,495
Used GMC Sonoma
9 Great Deals out of 433 listings starting at $1,000
Used Dodge Dakota
113 Great Deals out of 3,741 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.