car wont start without being jumped every time. Also have to put the positive cable on the terminal and not the battery itself or theres no spark or anything even while connected to another car or

Asked by May 26, 2016 at 01:35 AM about the Chevrolet Lumina

Question type: Maintenance & Repair

1 Answer

118,665

Sounds like bad battery cables or at the very least extremely dirty or badly corroded ones. Try cleaning them up first, just make sure there is no more of the black corrosion on the battery posts or the cable terminal ends. HTH

Your Answer:

Chevrolet Lumina Experts

  • #1
    90V6RedHotLuminaEuro
    Reputation
    1,270
  • #2
    John Saffrahn
    Reputation
    1,110
  • #3
    11jonny11
    Reputation
    990
View All

Related Models For Sale

Used Chevrolet Impala
517 Great Deals out of 26,173 listings starting at $995
Used Chevrolet Malibu
623 Great Deals out of 51,869 listings starting at $1,550
Used Chevrolet Monte Carlo
3 Great Deals out of 987 listings starting at $1,125
Used Chevrolet Camaro
262 Great Deals out of 27,422 listings starting at $2,900
Used Chevrolet Corvette
86 Great Deals out of 15,159 listings starting at $4,499
Used Buick Century
555 listings starting at $1,995
Used Toyota Camry
882 Great Deals out of 72,153 listings starting at $1,000
Used Ford Taurus
205 Great Deals out of 16,251 listings starting at $500
Used Ford Mustang
308 Great Deals out of 40,433 listings starting at $1,000
Used Honda Accord
719 Great Deals out of 103,450 listings starting at $849
Used Chevrolet Caprice
158 listings starting at $9,495
Used Ford Crown Victoria
4 Great Deals out of 747 listings starting at $2,995
Used Pontiac Grand Prix
13 Great Deals out of 1,691 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.