i got a 2007 chevy van that is giving me running rich code on bank one and two. it runs fine except for when u first crank it up, it will run bad for like five seconds. any ideas?

15

Asked by Jan 18, 2012 at 06:49 PM about the Chevrolet Chevy Van

Question type: Maintenance & Repair

2 Answers

395

check the fuel pressure regulator vacuum hose,probably has fuel shooting out of it all the time,its not supposed to,this is easy to spot and fix on these motors,first thing to check anyway.

395

change your oil if this is the problem,it'll wash down into the crankcase and you'll be running gas and oil in the crankcase,not good.

Your Answer:

Chevrolet Chevy Van Experts

  • #1
    John Saffrahn
    Reputation
    370
  • #2
    COMETGUY61
    Reputation
    260
  • #3
    Taylor Januskiewiecz
    Reputation
    210
View All

Related Models For Sale

Used Chevrolet Express Cargo
98 Great Deals out of 5,476 listings starting at $2,450
Used Chevrolet Express
26 Great Deals out of 4,297 listings starting at $3,995
Used GMC Savana
18 Great Deals out of 1,030 listings starting at $3,995
Used Dodge Ram Van
110 listings starting at $985
Used GMC Vandura
8 listings
Used Chevrolet Astro
149 listings starting at $1,600
Used GMC Savana Cargo
42 Great Deals out of 2,678 listings starting at $2,500
Used Ford E-Series Cargo
86 Great Deals out of 3,298 listings starting at $2,300
Used Chevrolet Astro Cargo
114 listings starting at $2,800
Used Ford E-Series Wagon
25 Great Deals out of 1,030 listings starting at $1,955
Used Ford E-150
114 listings starting at $2,991
Used Chevrolet Suburban
326 Great Deals out of 21,833 listings starting at $1,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.