i got a 2007 chevy van that is giving me running rich code on bank one and two. it runs fine except for when u first crank it up, it will run bad for like five seconds. any ideas?

15

Asked by Jan 18, 2012 at 06:49 PM about the Chevrolet Chevy Van

Question type: Maintenance & Repair

2 Answers

355

check the fuel pressure regulator vacuum hose,probably has fuel shooting out of it all the time,its not supposed to,this is easy to spot and fix on these motors,first thing to check anyway.

355

change your oil if this is the problem,it'll wash down into the crankcase and you'll be running gas and oil in the crankcase,not good.

Your Answer

Add photo

Related Questions

Search Chevrolet Chevy Van Questions

Chevrolet Chevy Van Experts

#1 John Saffrahn
John Saffrahn
Reputation 350
#2 COMETGUY61
COMETGUY61
Reputation 210
#2 1977g10shorty
1977g10shorty
Reputation 210
View All

Related Models For Sale

Used Chevrolet Express
41 Great Deals out of 5,027 listings starting at $1,995
Used Chevrolet Express Cargo
55 Great Deals out of 11,534 listings starting at $1,995
Used GMC Savana
4 Great Deals out of 1,228 listings starting at $3,500
Used Chevrolet Astro Cargo Van
130 listings starting at $1,975
Used Dodge Ram Van
118 listings
Used Ford E-Series Cargo
72 Great Deals out of 2,966 listings starting at $1,995
Used Chevrolet Astro
207 listings starting at $2,995
Used Chevrolet City Express
2,517 listings starting at $9,866
Used Ford E-350
224 listings starting at $1,200
Used GMC Vandura
12 listings
Used GMC Savana Cargo
27 Great Deals out of 3,814 listings starting at $2,500
Used Ford E-Series Wagon
32 Great Deals out of 1,216 listings starting at $2,750

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.