My 86 mercury marquis starts and runs perfect but after driving maybe 3 miles it cuts off and i have to wait for awhile for it to start back up

Asked by May 17, 2014 at 03:14 PM about the Mercury Grand Marquis

Question type: Maintenance & Repair

1 Answer

102,325

Sounds like a ignition problem, have you ever replaced the ignition module and distributor pickup?

Your Answer

Mercury Grand Marquis Experts

  • #1
    Tracy Hooks
    Reputation
    5,780
  • #2
    kbro
    Reputation
    2,150
  • #3
    Js08016
    Reputation
    1,880
View All

Related Models For Sale

Used Lincoln Town Car
45 Great Deals out of 1,758 listings starting at $1,000
Used Ford Crown Victoria
4 Great Deals out of 1,049 listings starting at $1,496
Used Chevrolet Impala
540 Great Deals out of 35,256 listings starting at $900
Used Dodge Charger
419 Great Deals out of 28,475 listings starting at $2,490
Used Ford F-150
2,575 Great Deals out of 199,191 listings starting at $1,300
Used Ford Mustang
592 Great Deals out of 36,389 listings starting at $899
Used Chevrolet Tahoe
730 Great Deals out of 41,715 listings starting at $1,995
Used Chrysler 300
335 Great Deals out of 18,060 listings starting at $990
Used Cadillac DTS
64 Great Deals out of 1,611 listings starting at $2,499
Used Cadillac DeVille
1,548 listings starting at $2,995
Used Lincoln Continental
17 Great Deals out of 3,857 listings starting at $35,890
Used Chevrolet Caprice
199 listings starting at $9,995
Used Ford Taurus
183 Great Deals out of 15,898 listings starting at $1,850
Used Buick LeSabre
18 Great Deals out of 1,771 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.