My 86 mercury marquis starts and runs perfect but after driving maybe 3 miles it cuts off and i have to wait for awhile for it to start back up

Asked by May 17, 2014 at 03:14 PM about the Mercury Grand Marquis

Question type: Maintenance & Repair

1 Answer

90,635

Sounds like a ignition problem, have you ever replaced the ignition module and distributor pickup?

Your Answer

Add photo

Related Questions

Search Mercury Grand Marquis Questions

Mercury Grand Marquis Experts

#1 Tracy Hooks
Tracy Hooks
Reputation 5,340
#2 kbro
kbro
Reputation 2,050
#3 Js08016
Js08016
Reputation 1,710
View All

Related Models For Sale

Used Ford Crown Victoria
11 Great Deals out of 1,045 listings starting at $2,995
Used Lincoln Town Car
30 Great Deals out of 1,841 listings starting at $600
Used Chevrolet Impala
500 Great Deals out of 29,108 listings starting at $1,100
Used Dodge Charger
287 Great Deals out of 26,815 listings starting at $2,250
Used Mercury Marauder
26 listings starting at $9,367
Used Lincoln Continental
4,154 listings starting at $42,000
Used Cadillac DeVille
8 Great Deals out of 1,584 listings starting at $1,499
Used Chrysler 300
337 Great Deals out of 20,380 listings starting at $1,000
Used Ford Mustang
372 Great Deals out of 46,984 listings starting at $1,500
Used Ford F-150
2,237 Great Deals out of 209,413 listings starting at $1,499
Used Ford Taurus
205 Great Deals out of 20,162 listings starting at $1,510
Used Cadillac DTS
44 Great Deals out of 1,626 listings starting at $2,250
Used Chevrolet Tahoe
557 Great Deals out of 27,464 listings starting at $999
Used Honda Accord
711 Great Deals out of 87,160 listings starting at $699
Used Chevrolet Caprice
150 listings starting at $10,490