63 Falcon Speedometer Problem.

Asked by Jan 15, 2012 at 11:36 AM about the Ford Falcon

Question type: Maintenance & Repair

Hello, I have a 63 Falcon. The problem is the speedometer, I replaced the cable and
still nothing. When in drive the speedometer is reading 100. When going in reverse
the speedometer works from 100 to 0. What might be the problem or a fix.

Thanks.

1 Answer

try replaceing the plastic gear at tranny where the speed o cable hooks at.

Your Answer:

Ford Falcon Experts

  • #1
    Troy Witt
    Reputation
    580
  • #2
    MrBlueOval
    Reputation
    380
  • #3
    Thadius
    Reputation
    130
View All

Related Models For Sale

Used Ford Mustang
273 Great Deals out of 37,795 listings starting at $1,350
Used Ford Fairlane
71 listings
Used Ford Torino
45 listings
Used Ford Galaxie
100 listings
Used Chevrolet Camaro
232 Great Deals out of 27,541 listings starting at $2,800
Used Ford Thunderbird
17 Great Deals out of 1,071 listings starting at $6,498
Used Ford Ranchero
42 listings
Used Ford Maverick
4 listings
Used Chevrolet Corvette
83 Great Deals out of 15,126 listings starting at $3,620
Used Chevrolet Impala
448 Great Deals out of 25,776 listings starting at $950
Used Ford F-150
2,239 Great Deals out of 210,391 listings starting at $1,300
Used Chevrolet Nova
136 listings
Used BMW 3 Series
921 Great Deals out of 31,704 listings starting at $900
Used Ford Focus RS
1,496 listings starting at $27,798

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.