electronic instrument cluster failure?

25

Asked by Jun 02, 2008 at 09:02 AM about the 1988 Chrysler Le Baron

Question type: Maintenance & Repair

The "Check Engine" & "Check Gauge" messages dimly illuminated on the main panel electronic instrument cluster a few times in the last month. When I turned the car of and restarted the engine the messages went away.  Then today coming to work, the entire main panel electronic instrument cluster went blank. Again, when I turned the car off and restarted the engine everything was ok and the entire cluster came back on.  What could be the problem?  Also, the relay on the AC compresser is in need of replacement (waiting for part). Could this have anything to do with the cluster problem?

1 Answer

44,205

Had this problem with an '90 Buick Riviera. The early digital dashes were known for power supply failures. You can have this rebuilt online, for around $200. The A/C compressor problem is not likely linked to your dash problem. My Rivi would lose digital dash function entirely, at random, when driving, seemed like maybe as the power supply heated up? That was the prescribed fix though, to have it rebuilt.

Your Answer

Chrysler Le Baron Experts

  • #1
    dandyoun
    Reputation
    310
  • #2
    chassy
    Reputation
    200
  • #3
    TopShadeTree
    Reputation
    180
View All

Related Models For Sale

Used Ford Mustang
743 Great Deals out of 42,668 listings starting at $1,300
Used Honda Accord
1,000 Great Deals out of 62,552 listings starting at $999
Used Chevrolet Caprice
177 listings starting at $34,100
Used Pontiac Firebird
12 Great Deals out of 817 listings starting at $1,900
Used Chrysler TC
19 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.