I have a 2000 venture lights and radio come on because I got a boost, however even with boost car won't start it won't even make a sound like it's even trying to start! What is it ?someone please !

Asked by Mar 27, 2014 at 02:45 PM about the 2000 Chevrolet Venture

Question type: Maintenance & Repair

1 Answer

254,175

Could be the battery died, can you check the voltage? Should be 12.3V or higher. If that is OK, it could be a ground problem. Check your battery cables for corrosion.

Your Answer

Chevrolet Venture Experts

  • #1
    Tom Demyan
    Reputation
    590
  • #2
    John Carson
    Reputation
    380
  • #3
    carGrrl
    Reputation
    340
View All

Related Models For Sale

Used Dodge Grand Caravan
197 Great Deals out of 26,952 listings starting at $1,750
Used Honda Odyssey
322 Great Deals out of 23,522 listings starting at $950
Used Chevrolet Express
53 Great Deals out of 4,973 listings starting at $3,500
Used Chrysler Town & Country
247 Great Deals out of 14,022 listings starting at $1,998
Used Chevrolet Tahoe
658 Great Deals out of 39,224 listings starting at $1,000
Used Chevrolet Suburban
332 Great Deals out of 21,586 listings starting at $1,900
Used Toyota Sienna
301 Great Deals out of 26,330 listings starting at $1,700
Used Pontiac Montana
277 listings starting at $1,950
Used Ford Windstar
643 listings starting at $1,800
Used Ford Explorer
805 Great Deals out of 62,574 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.