Lumina LTZ 2007 Starting problem & sound while driving especially on rough roads in the morning

Asked by Dec 29, 2017 at 03:15 PM about the 2001 Chevrolet Lumina

Question type: Maintenance & Repair

Two weeks back bought a used Lumina LTZ 2007 model. Over 155342
miles driven car. Loving this american car. Found two complaints so far

1. Had ignition problem when bought, changed battery but after one week
again same starting problem there is a lag, when assisted with accelerator
pedal it gets started.
2. In the morning while driving on the rough roads some sort of chain
sound comes and after driving for some time then it is normal not much
sound. My friend told may be link rod bush needs to be changed

Kindly advise

1 Answer

Thank you Tom. I will check the same

Your Answer:

Chevrolet Lumina Experts

  • #1
    90V6RedHotLuminaEuro
    Reputation
    1,320
  • #2
    John Saffrahn
    Reputation
    1,160
  • #3
    11jonny11
    Reputation
    1,040
View All

Related Models For Sale

Used Chevrolet Impala
678 Great Deals out of 25,870 listings starting at $1,295
Used Chevrolet Monte Carlo
6 Great Deals out of 812 listings starting at $1,499
Used Chevrolet Camaro
694 Great Deals out of 28,940 listings starting at $2,499
Used Buick LeSabre
1,000 listings starting at $1,799
Used Ford F-150
4,272 Great Deals out of 222,413 listings starting at $850
Used Chevrolet Silverado 2500HD
566 Great Deals out of 34,800 listings starting at $2,000
Used Mercury Grand Marquis
16 Great Deals out of 1,098 listings starting at $950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.