I replaced the fuel pump in my 1972 cadillac eldorado and installed an inline glass fuel filter. it ran great for one day, it stalled on me today and would not start. i checked under the hood and there wasn't any fuel in the see through filter . i tried starting the car several times but it remained empty. i waited about an hour and tried it again, the filter filled up and the car started. I drove home about 5 miles w/o a hitch. i would like to know what cause fuel to fail to reach the carburetor?

40

Asked by Aug 16, 2014 at 10:23 PM about the 1972 Cadillac Eldorado

Question type: General

12 Answers

97,225

I have seen this a few times before, 1 rig in my shop had crud in the fuel tank that would get sucked up into the pickup screen blocking the fuel flow and killing the engine, once the vacuum pull from the pump stopped the crud would fall of and after a little cranking it would start and run till it was plugged again, removed tank and had it cleaned and sealed problem was gone, the other one had a fuel line that would collapse and shut off the fuel supply, engine would die from no fuel, fuel up draw would stop, hose would go back to normal engine would restart and it would do it again, and finall another rig just had a new fuel pump put on, it would drive for about 10 minutes then quit, out of fuel, wait a few minutes it would restart, it was a bad new pump. Just something's I have ran across.

2 of 2 people found this helpful.
112,415

Ok this might be a long shot but my brother once had someone drop some rubber pieces in his gas tank. He could drive fine for days or at times only miles then his filter would do the same. The items would float around fuel tank till they would get sucked to the inlet stopping the flow. Until the pressure released and they floated away no gas would pump thru pump. Took us months to get this figured out and tank cleaned out. Cause it only happened when ever it damn well wanted to. That being said I doubt this is your issue but it is a possibility that something in your old tank is doing the same.

1 of 1 people found this helpful.
112,415

Damn. Almost same description. Lol

40

I removed the fuel tank, clean as a whistle. replaced tank with new sending unit, another new fuel pump and another new carbureutor. I didnt even make it home from the shop. absolutely no fuel is being pump to the carbuerator now. Im going to run a rubber fuel line from the tank to the fuel pump to see if that works. My mechanic thanks there may be a crack or hole in the fuel line causing it to suck air. I dont know anything else to do. I"m about to lose my damm MIND! HELP ME SOMEBODY.

97,225

Have you tried to run it without the fuel cap?

40

Not yet. I was putting a gravity fed electric fuel pump on but my lines are on top of the tank. I put a suction pull (tank side), push (carb side) pump on and I'm now testing it for a few days. if this doesn't work I'm going to run a rubber fuel ine from the tank. So far so good. Thanks.

112,415

Just a thought but might want to inspect the metal fuel line from the tank to the engine. Have seen them get bent (smashed flat) against the frame rail and restrict the fuel flow.

97,225

How far from the tank is the fuel pump? They are not designed to pull much more than 18 inches. They can push good but pulling is not the best.

40

It's about 30 inches. I exchanged the old one for a new one today and will be putting it on tommorrow. I dont know how close I can get it to the tank but I'll try. There was nowhere else to safely mount it when I put it in the first time except along the driver's side railing where the fuel lines run. I will let you know.

35

This thread is still alive. I have a 72 Eldo as well. Same freaking issue. Changed everything, Carb, Distributor, Fuel pump, Wires, Spark plugs - everything. Just bought a new sending unit - should be here next week. Waiting to drop the gas tank until the unit gets here. Gonna hoist it up - and inspect the fuel lines thoroughly, not to mention the tank. Please - if you get yours going - lemme know what it was. Literally the same issue you're facing - except mine won't run for days, quits almost every time i take it out. By the way, did you remove your air pump?

I am restoring a 72 Eldorado. Had installed all new fuel components with rebuilt carb. While driving the motor stalled. Was not getting fuel to carb. After several checks found out the new fuel pump arm was not making good contact with the cam. The arm was just making a enough contact to run until it wore to the point of failing. So if all else fails to correct the problem check the fuel pump arm.

35

Did you get a new gas tank? I've been looking everywhere. Can't find one. My problem was the sock at the end of the sending unit would get clogged up with very fine rust. Said screw that and installed a giant inline filter right after the gas tank - in a loop so that there's enough slack. Anyways. Fixed my problem. I just gotta change that inline filter every now and then. I get these clear plastic ones. As you can see in the pic - they get kinda gross. Need a new tank. May help for you. The test vaccuum on everything. See if you can get negative pressure on the two lines that go to the tank. One sucks up from the tank - which connects to the long tube on the sending. The other is the return. They both gotta be good. Maybe your lines are crossed somewhere. Probably up front. You may be sucking from the tall tube. Vapours.

Your Answer

Add photo

Related Questions

Eldorado

Looking for a Used Eldorado in your area?

CarGurus has 349 nationwide Eldorado listings and the tools to find you a great deal.

ZIP:

Search Cadillac Eldorado Questions

Cadillac Eldorado Experts

#1 spiderblu
spiderblu
Reputation 810
#2 Js08016
Js08016
Reputation 330
#3 COMETGUY61
COMETGUY61
Reputation 300
View All

Related Models For Sale

Used Cadillac DeVille
1,732 listings starting at $1,995
Used Chevrolet Corvette
231 Great Deals out of 22,297 listings starting at $3,750
Used Ford Mustang
723 Great Deals out of 44,327 listings starting at $1,500
Used Chevrolet Impala
554 Great Deals out of 35,525 listings starting at $899
Used Chevrolet Camaro
368 Great Deals out of 31,396 listings starting at $2,400
Used Lincoln Continental
12 Great Deals out of 4,713 listings starting at $34,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.