no response for temp gauge but the light is on

JfdiscII
75

Asked by Mar 14, 2013 at 09:43 AM about the 2003 Land Rover Discovery

Question type: Maintenance & Repair

no response for temp gauge but the light is on and when you starts the gauge will cycle -- did blow a
hose and repalced that and the thermostat

4 Answers

yawtee
5

change the hose again

JfdiscII
75

hose is good -- do you think i have a air pocket

tenspeed
87,085

If there is an air pocket, that could do it. Bleed out the air. If the gauge is still out, check the sending unit with a meter. It provides the ground connection for the gauge. If you ground the gauge wire, the gauge should read full scale (hot).

1 out of 1 people think this is helpful.
JfdiscII
75

i fixed it -- i added more fluid with the engine running for about five min - then disconnected the battery and all lights went off and gauges started working - still hear a little gurgle in heater core but that should go away in a few long drives -- also played with the temp sensor maybe that did some thing as well

Your Answer

Add photo

Related Questions

Discovery

Looking for a Used Discovery in your area?

CarGurus has 210 nationwide Discovery listings and the tools to find you a great deal.

ZIP:

Search Land Rover Discovery Questions

Land Rover Discovery Experts

#1 Simon Briggs
Simon Briggs
Reputation 350
#2 chassy
chassy
Reputation 300
#3 Matt Mankinen
Matt Mankinen
Reputation 290
View All

Related Models For Sale

Used Land Rover Range Rover"
131 Great Deals out of 4,697 listings starting at $4,500
Used Land Rover Defender"
67 listings starting at $38,987
Used Toyota 4Runner"
341 Great Deals out of 16,739 listings starting at $1,900
Used Land Rover Freelander"
84 listings starting at $3,950
Used Toyota Land Cruiser"
22 Great Deals out of 1,183 listings starting at $4,500
Used Jeep Wrangler"
331 Great Deals out of 14,496 listings starting at $2,795
Used Jeep Grand Cherokee"
1,142 Great Deals out of 73,769 listings starting at $495