1989 240dl station wagon. Recently passed Smog and car was running fine. now 10 days after smog test I parked it went back out the next morning and it would'nt start.

Asked by Sep 09, 2012 at 11:26 AM about the 1989 Volvo 240

Question type: Maintenance & Repair

the engine turns over but no ignition. its making a noise behind the glove box that was never there before.  I know its not much to go on but it  might make sense to an expert. thanks

1 Answer

270,145

The noise is the fuel pump relay. Either the relay failed or the wired connections are bad. You can remove and take the replay apart and check the solder for a fault connection. http://www.youtube.com/watch?v=-AtL_8ugdnE

3 of 3 people found this helpful.

Your Answer

Volvo 240 Experts

  • #1
    Tom Demyan
    Reputation
    270
  • #2
    ytlas
    Reputation
    70
  • #3
    burner
    Reputation
    60
View All

Related Models For Sale

Used Volvo 740
5 listings
Used Volvo 760
2 listings
Used BMW 3 Series
1,136 Great Deals out of 33,416 listings starting at $1,428
Used Ford Mustang
460 Great Deals out of 42,891 listings starting at $1,488
Used Volvo 780
1 listing
Used Honda Civic
736 Great Deals out of 54,085 listings starting at $1,495
Used Mazda MX-5 Miata
77 Great Deals out of 3,977 listings starting at $2,995

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.