Acura Legend Coupe

Asked by Sep 03, 2014 at 09:20 PM about the 1989 Acura Legend

Question type: Maintenance & Repair

My acura is having starting problem. It turns over but doesn't start some times. It is intermittent problem. If I wait awhile it will start. AAA put in new battery one month ago and battery reads good battery. The computer reading on starter test said low cranking amps. Voltage 11.47, .1Amps, time was 1.03 sec.
Any idea what the problem is and how much a repair would be?

2 Answers

67,565

Have you checked the fuel pressure,may be fuel pump.

1 of 1 people found this helpful.
140

pgmfi main relay, common on legends

2 of 2 people found this helpful.

Your Answer

Acura Legend Experts

  • #1
    maddison
    Reputation
    250
  • #2
    Logan Saunders
    Reputation
    180
  • #3
    Monique Bell
    Reputation
    150
View All

Related Models For Sale

Used Honda Accord
1,031 Great Deals out of 61,614 listings starting at $999
Used Acura Integra
115 listings starting at $1,475
Used Nissan Maxima
342 Great Deals out of 23,515 listings starting at $1,550
Used Ford Mustang
743 Great Deals out of 42,277 listings starting at $1,300
Used BMW 7 Series
163 Great Deals out of 5,982 listings starting at $2,500
Used Chevrolet Camaro
398 Great Deals out of 31,729 listings starting at $2,395

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.