Acura Legend Coupe

Asked by Sep 03, 2014 at 09:20 PM about the 1989 Acura Legend

Question type: Maintenance & Repair

My acura is having starting problem. It turns over but doesn't start some times. It is intermittent problem. If I wait awhile it will start. AAA put in new battery one month ago and battery reads good battery. The computer reading on starter test said low cranking amps. Voltage 11.47, .1Amps, time was 1.03 sec.
Any idea what the problem is and how much a repair would be?

2 Answers


Have you checked the fuel pressure,may be fuel pump.

1 of 1 people found this helpful.

pgmfi main relay, common on legends

2 of 2 people found this helpful.

Your Answer

Acura Legend Experts

  • #1
  • #2
    Logan Saunders
  • #3
    Monique Bell
View All

Related Models For Sale

Used Honda Accord
543 Great Deals out of 93,124 listings starting at $1,495
Used Acura Integra
83 listings starting at $2,495
Used Toyota Camry
781 Great Deals out of 71,413 listings starting at $175
Used Honda Civic
351 Great Deals out of 51,806 listings starting at $1,200
Used Nissan Maxima
239 Great Deals out of 17,866 listings starting at $1,995
Used Chevrolet Camaro
248 Great Deals out of 29,861 listings starting at $4,980
Used BMW 7 Series
116 Great Deals out of 4,984 listings starting at $2,699

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.