Oldsmobile '92 88

Asked by Jun 26, 2016 at 06:35 PM about the 1992 Oldsmobile Eighty-Eight Royale

Question type: Maintenance & Repair

Olds 92 88 not firing chaged out 2 coils, mass air
flow intake, ignition switch & module, twice chafed
the ignition module. Question might it b the crank
sensor? Help!!! Thanks

1 Answer

5,915

I'm going to suggest the connection from the battery negative...to the engine...and to the chassis...yes the CABLE capable of 80 amps...make sure the battery is new...and not 5 years old...so full potential...not dropping under load can be realized~ the electronics are delicate and need to see clean power not dropping under load~ new cables and battery should be the recipe for the problem here~

Your Answer

Oldsmobile Eighty-Eight Royale Experts

  • #1
    Michael Urbanski
    Reputation
    270
  • #2
    John Saffrahn
    Reputation
    240
  • #3
    Tom Demyan
    Reputation
    150
View All

Related Models For Sale

Used Buick LeSabre
5 Great Deals out of 1,692 listings starting at $899
Used Chevrolet Caprice
150 listings starting at $9,995
Used Lexus LS 400
178 listings starting at $2,500
Used Ford Explorer
1,267 Great Deals out of 70,072 listings starting at $1,000
Used Nissan Maxima
331 Great Deals out of 21,807 listings starting at $1,200
Used Lincoln Town Car
27 Great Deals out of 1,686 listings starting at $1,099
Used Cadillac DeVille
6 Great Deals out of 1,496 listings starting at $1,999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.