I have turn signal in front, but not on the sides or back

Asked by Nov 08, 2017 at 08:03 PM about the 1993 Ford E-350

Question type: Maintenance & Repair

I have a 1993 E-350 bus, and my front turn signals and
hazards work, but not in the back. My brake lights work, my
running lights work, but signal lights in the back don't work
at all. I've checked the fuse which is good, my lights are
new, and I can't find the problem.

1 Answer

8,215

to find the problem you will need a multi tester to see where there is power and where there is not , everything needs a ground and old bulb sockets can do funny things , being a bus they may have wired it differently from the usual fords , look for obvious wires going towards the back under neath the vehicle ,

Your Answer:

Ford E-350 Experts

  • #1
    Tracy Hooks
    Reputation
    480
  • #2
    tennisshoes
    Reputation
    300
  • #3
    Opal Allen
    Reputation
    260
View All

Related Models For Sale

Used Ford F-350
192 listings starting at $8,850
Used Ford E-150
109 listings starting at $8,995
Used Ford F-150
3,022 Great Deals out of 195,502 listings starting at $1,000
Used Ford F-250
367 listings starting at $1,950
Used Ford Transit Cargo
106 Great Deals out of 18,425 listings starting at $10,500
Used Ford E-250
58 listings

Used Cars for Sale

1996 Ford E-350 For Sale
12 listings starting at $2,498

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.