Backup lights don't work

5

Asked by Sep 23, 2010 at 12:16 AM about the 1961 Ford Thunderbird

Question type: Maintenance & Repair

Both bulbs test ok. I've tried this with the engine running, lights on and reverse selected. Is there a fuse somewhere?

Thanks,

Spencer

2 Answers

no ,no fuse,sounds like a ground problem or broken wire,also check on the break master cylender,to the side of it,is where the back up light switch is on your car.

125

may not have a good ground in wiring, or check switch around gear lever

Your Answer

Add photo

Related Questions

Search Ford Thunderbird Questions

Ford Thunderbird Experts

#1 Larry Sturgis
Larry Sturgis
Reputation 1,560
#2 Tom Demyan
Tom Demyan
Reputation 1,490
#3 tennisshoes
tennisshoes
Reputation 1,220
View All

Related Models For Sale

Used Chevrolet Corvette
121 Great Deals out of 20,599 listings starting at $3,000
Used Mercedes-Benz SL-Class
40 Great Deals out of 2,840 listings starting at $3,500
Used Lincoln Continental
4,475 listings starting at $40,000
Used Chevrolet Impala
578 Great Deals out of 31,558 listings starting at $799

Used Cars For Sale

2005 Ford Thunderbird For Sale
75 listings starting at $10,882
2004 Ford Thunderbird For Sale
5 Great Deals out of 146 listings starting at $7,985
2003 Ford Thunderbird For Sale
6 Great Deals out of 163 listings starting at $8,995
2002 Ford Thunderbird For Sale
8 Great Deals out of 330 listings starting at $6,499

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.