Runs rough and/or stalls at start till warmed up.infrequent black smoke at start, per daughter (her car)i've not seen it. New air filter,alternator, haven't replaced plugs. Can idle be adjusted on EFI? Runs fine after warms up.

25

Asked by Jul 05, 2007 at 07:27 PM about the 1989 Ford Escort

Question type: Maintenance & Repair

1 Answer

34,795

Could be a few things. Try using this site site to troubleshoot the issue. http://autozone.com/UseCase,S001/UserAction,viewSimpleDiagInfo/Parameters,info/getInTheZone.htm

1 people found this helpful.

Your Answer

Ford Escort Experts

  • #1
    Tom Demyan
    Reputation
    1,090
  • #2
    dandyoun
    Reputation
    900
  • #3
    tennisshoes
    Reputation
    440
View All

Related Models For Sale

Used Ford Mustang
255 Great Deals out of 36,640 listings starting at $2,500
Used Ford Taurus
175 Great Deals out of 15,814 listings starting at $981
Used Honda Civic
343 Great Deals out of 52,179 listings starting at $1,200
Used Ford Fiesta
100 Great Deals out of 17,297 listings starting at $2,911
Used Ford F-150
2,328 Great Deals out of 214,863 listings starting at $1,300
Used Chevrolet Camaro
237 Great Deals out of 28,850 listings starting at $1,800
Used Ford Ranger
117 Great Deals out of 4,546 listings starting at $1,195
Used Toyota Corolla
581 Great Deals out of 66,686 listings starting at $900
Used Honda Accord
429 Great Deals out of 101,194 listings starting at $995
Used Toyota Camry
794 Great Deals out of 70,474 listings starting at $1,000

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.