Runs rough and/or stalls at start till warmed up.infrequent black smoke at start, per daughter (her car)i've not seen it. New air filter,alternator, haven't replaced plugs. Can idle be adjusted on EFI? Runs fine after warms up.

25

Asked by Jul 05, 2007 at 07:27 PM about the 1989 Ford Escort

Question type: Maintenance & Repair

1 Answer

33,205

Could be a few things. Try using this site site to troubleshoot the issue. http://autozone.com/UseCase,S001/UserAction,viewSimpleDiagInfo/Parameters,info/getInTheZone.htm

1 of 1 people found this helpful.

Your Answer

Ford Escort Experts

  • #1
    Tom Demyan
    Reputation
    1,050
  • #2
    dandyoun
    Reputation
    880
  • #3
    tennisshoes
    Reputation
    430
View All

Related Models For Sale

Used Ford Mustang
602 Great Deals out of 39,738 listings starting at $1,988
Used Ford F-150
3,252 Great Deals out of 223,478 listings starting at $1,200
Used Ford Fiesta
151 Great Deals out of 16,469 listings starting at $2,215
Used Honda Civic
834 Great Deals out of 61,319 listings starting at $950
Used Ford Taurus
245 Great Deals out of 15,127 listings starting at $1,800
Used Toyota Corolla
963 Great Deals out of 66,718 listings starting at $1,699
Used Toyota Camry
1,104 Great Deals out of 87,563 listings starting at $995
Used Ford Ranger
202 Great Deals out of 5,575 listings starting at $995
Used Honda Accord
1,111 Great Deals out of 74,387 listings starting at $1,100

Used Cars For Sale

2002 Ford Escort For Sale
48 listings starting at $899

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.