1989 Chevy Full Size 4x4 Blazer won't go past 1st gear, then revs up, also leaking very little transmission fluid, what can be wrong?

Asked by Oct 09, 2012 at 03:33 PM about the 1989 Chevrolet Blazer

Question type: Maintenance & Repair

Transmission does not go past first gear then sounds very accelerated at about 20mph I can let go of accelerator just a bit and it goes in to gear at about 17-18 mph.  I noticed it was leaking very little trans. fluid.  The fluid was low because I put in 4 quarts of fluid.  Blazer doesn't make any other noises either.  What can cause this?

2 Answers

Many things like the gears in the transmission could be going

1 out of 1 people think this is helpful.

There is an electric plug that goes in the side of your transmission. I had the same problem after having some electrical work done. Mine was unplugged. Plug it back in and you should be able to shift through all gears now.

Your Answer

Add photo

Related Questions

Search Chevrolet Blazer Questions

Chevrolet Blazer Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 1,900
#2 yetilikesbeer
yetilikesbeer
Reputation 1,190
#3 Rowefast
Rowefast
Reputation 820
View All

Related Models For Sale

Used Chevrolet S-10
10 Great Deals out of 1,656 listings starting at $2,450
Used GMC Jimmy
288 listings starting at $1,995
Used Ford Bronco
192 listings
Used Ford F-150
2,700 Great Deals out of 212,349 listings starting at $1,000
Used Chevrolet Camaro
279 Great Deals out of 38,301 listings starting at $1,250
Used Chevrolet C/K 1500
1,048 listings starting at $2,000

Used Cars For Sale

2003 Chevrolet Blazer For Sale
115 listings starting at $1,995
2001 Chevrolet Blazer For Sale
185 listings starting at $2,495