engine runs rough plus check engine light is on

Asked by Dec 21, 2010 at 05:05 PM about the 1997 Toyota T100

Question type: Maintenance & Repair

I have replaced plugs, wires, exhaust pipe, o2 sensors, all by a mechanic......  he says it's probably the injectors.  It runs well on cold start, but if i turn engine off and restart it will run rough the rest of the time.  I will gladly put more money into it, but I'm tired of dumping it into a black hole.  Please Help,   Arch

1 Answer

45

vacuum leak? did they check for vacuum leaks?

2 people found this helpful.

Your Answer

Toyota T100 Experts

  • #1
    BURT100
    Reputation
    230
  • #2
    Tom Demyan
    Reputation
    210
  • #3
    mountainman1
    Reputation
    140
View All

Related Models For Sale

Used Toyota Tacoma
439 Great Deals out of 44,078 listings starting at $1,995
Used Toyota 4Runner
281 Great Deals out of 32,848 listings starting at $950
Used Ford F-150
2,344 Great Deals out of 215,477 listings starting at $1,300
Used Nissan Frontier
267 Great Deals out of 24,625 listings starting at $1,550
Used Toyota Land Cruiser
10 Great Deals out of 1,114 listings starting at $5,000
Used Ford Ranger
116 Great Deals out of 4,571 listings starting at $1,895
Used Toyota Supra
50 listings
Used Chevrolet S-10
10 Great Deals out of 957 listings starting at $950

Used Cars For Sale

1996 Toyota T100 For Sale
14 listings starting at $7,490

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.