engine runs rough plus check engine light is on

Asked by Dec 21, 2010 at 05:05 PM about the 1997 Toyota T100

Question type: Maintenance & Repair

I have replaced plugs, wires, exhaust pipe, o2 sensors, all by a mechanic......  he says it's probably the injectors.  It runs well on cold start, but if i turn engine off and restart it will run rough the rest of the time.  I will gladly put more money into it, but I'm tired of dumping it into a black hole.  Please Help,   Arch

1 Answer

45

vacuum leak? did they check for vacuum leaks?

2 of 2 people found this helpful.

Your Answer

Toyota T100 Experts

  • #1
    BURT100
    Reputation
    190
  • #2
    Tom Demyan
    Reputation
    170
  • #3
    tnseetitan
    Reputation
    120
View All

Related Models For Sale

Used Toyota Tacoma
555 Great Deals out of 41,950 listings starting at $2,000
Used Toyota 4Runner
240 Great Deals out of 21,537 listings starting at $2,300
Used Toyota Land Cruiser
10 Great Deals out of 1,010 listings starting at $4,990
Used Ford F-150
2,189 Great Deals out of 182,390 listings starting at $1,000
Used Nissan Frontier
318 Great Deals out of 20,956 listings starting at $1,995
Used Toyota Supra
58 listings
Used Ford Ranger
172 Great Deals out of 5,559 listings starting at $1,000
Used Chevrolet S-10
6 Great Deals out of 1,283 listings starting at $1,800

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.