No power in drive, why?

Asked by Mar 30, 2011 at 03:06 PM about the 1997 Toyota Previa

Question type: Maintenance & Repair

97 Previa has been completely "gone through" by reputable mechanic.  Van purchased from little old lady who let it over heat and die on last drive. Needed parts have been replaced, wiring checked out, engine gone thru. Will crank and go, but only in "limp mode", no power. My mechanic is pulling his hair out. I suspect something simple. Any ideas--Please?!?!

1 Answer

150

i had the same problem, mine only would drive on first gear, I checked the transmission sensor on the driver side and connection was rusted. after cleaning it and sanding it, problem solved. hope this helps.

Your Answer

Add photo

Related Questions

Search Toyota Previa Questions

Toyota Previa Experts

#1 ttdsgnr5
ttdsgnr5
Reputation 170
#2 her94previa
her94previa
Reputation 150
#2 gertis
gertis
Reputation 150
View All

Related Models For Sale

Used Toyota Sienna
250 Great Deals out of 28,729 listings starting at $2,180
Used Honda Odyssey
231 Great Deals out of 19,601 listings starting at $1,444
Used Toyota Corolla
972 Great Deals out of 69,275 listings starting at $1,999
Used Toyota 4Runner
237 Great Deals out of 18,867 listings starting at $2,195
Used Toyota Tacoma
516 Great Deals out of 42,738 listings starting at $1,995
Used Toyota Camry
1,197 Great Deals out of 84,710 listings starting at $750
Used Honda Civic
862 Great Deals out of 85,137 listings starting at $500
Used Audi A4
296 Great Deals out of 10,584 listings starting at $1,200
Used Toyota Tercel
35 listings
Used Jeep Wrangler
253 Great Deals out of 15,844 listings starting at $2,695

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.