1990 4.3 v6 idle issues when you start it up

Asked by Jan 18, 2017 at 05:53 PM about the 1990 Chevrolet S-10

Question type: Maintenance & Repair

I start it up and idle goes high then drops real low and then back to normal
idle them eventually cuts off after repeated process. I have replaced vacuum
lines, idle control sensor, throttle position sensor, and I'm still having the same
problems. Just curious if anyone could help me out.

2 Answers

113,645

Have you check for a leak on the gasket for the throttle body?

Yeah I sprayed all around that and didn't find any

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,560
  • #2
    John Saffrahn
    Reputation
    1,050
  • #3
    Trebor66
    Reputation
    1,040
View All

Related Models For Sale

Used Ford Ranger
197 Great Deals out of 5,574 listings starting at $995
Used GMC Sonoma
4 Great Deals out of 428 listings starting at $2,150
Used Ford F-150
3,305 Great Deals out of 224,467 listings starting at $1,200
Used Dodge Dakota
86 Great Deals out of 3,625 listings starting at $1,499
Used Chevrolet Blazer
7 Great Deals out of 922 listings starting at $950
Used GMC Sierra 1500
1,226 Great Deals out of 64,898 listings starting at $999
Used Chevrolet C/K 1500
815 listings starting at $2,436
Used Chevrolet Camaro
443 Great Deals out of 31,892 listings starting at $1,450
Used Ford Mustang
600 Great Deals out of 39,965 listings starting at $1,895

Used Cars For Sale

2004 Chevrolet S-10 For Sale
49 listings starting at $4,995
2003 Chevrolet S-10 For Sale
5 Great Deals out of 291 listings starting at $1,600
2002 Chevrolet S-10 For Sale
3 Great Deals out of 200 listings starting at $1,900
2001 Chevrolet S-10 For Sale
161 listings starting at $2,400
2000 Chevrolet S-10 For Sale
170 listings starting at $4,997

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.