1990 4.3 v6 idle issues when you start it up

Asked by Jan 18, 2017 at 05:53 PM about the 1990 Chevrolet S-10

Question type: Maintenance & Repair

I start it up and idle goes high then drops real low and then back to normal
idle them eventually cuts off after repeated process. I have replaced vacuum
lines, idle control sensor, throttle position sensor, and I'm still having the same
problems. Just curious if anyone could help me out.

2 Answers

111,095

Have you check for a leak on the gasket for the throttle body?

Yeah I sprayed all around that and didn't find any

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,450
  • #2
    John Saffrahn
    Reputation
    1,040
  • #3
    Trebor66
    Reputation
    1,030
View All

Related Models For Sale

Used Ford Ranger
146 Great Deals out of 5,427 listings starting at $800
Used GMC Sonoma
5 Great Deals out of 409 listings starting at $2,200
Used Ford F-150
2,579 Great Deals out of 199,186 listings starting at $1,300
Used Dodge Dakota
88 Great Deals out of 3,679 listings starting at $1,750
Used Chevrolet Blazer
3 Great Deals out of 1,071 listings starting at $950
Used GMC Sierra 1500
1,016 Great Deals out of 66,363 listings starting at $2,495
Used Chevrolet Camaro
446 Great Deals out of 30,844 listings starting at $1,450
Used Chevrolet C/K 1500
881 listings starting at $1,900

Used Cars For Sale

2004 Chevrolet S-10 For Sale
4 Great Deals out of 58 listings starting at $2,900
2003 Chevrolet S-10 For Sale
8 Great Deals out of 306 listings starting at $1,600
2002 Chevrolet S-10 For Sale
4 Great Deals out of 209 listings starting at $2,000
2001 Chevrolet S-10 For Sale
3 Great Deals out of 149 listings starting at $1,995
2000 Chevrolet S-10 For Sale
183 listings starting at $2,750

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.