What. Makes ac blower relay keep going bad ie high speed connection. Getting hot and not working. ..

Asked by Jul 25, 2014 at 11:05 AM about the 1994 Chevrolet S-10 Blazer

Question type: Maintenance & Repair

Replaced resistor other speeds started.
Working replaced relay high worked. Then
stopped...after a week...

1 Answer

101,875

Excessive motor amperage draw on start up. I had a Buick doing the same thing, I went through 2 relays within a week, replaced the blower motor and problem went away.

1 of 1 people found this helpful.

Your Answer

Chevrolet S-10 Blazer Experts

  • #1
    carGrrl
    Reputation
    1,540
  • #2
    Cody Doud
    Reputation
    660
  • #3
    emtfirefighter77
    Reputation
    380
View All

Related Models For Sale

Used Chevrolet S-10
16 Great Deals out of 1,265 listings starting at $1,995
Used Chevrolet Blazer
5 Great Deals out of 1,090 listings starting at $950
Used Ford Ranger
167 Great Deals out of 5,460 listings starting at $800
Used Chevrolet Tahoe
722 Great Deals out of 41,289 listings starting at $1,995
Used Ford F-150
2,540 Great Deals out of 193,420 listings starting at $799
Used Chevrolet C/K 1500
850 listings starting at $2,000
Used Chevrolet Suburban
379 Great Deals out of 22,593 listings starting at $1,999
Used Toyota Tacoma
570 Great Deals out of 43,899 listings starting at $2,500
Used Chevrolet Impala
548 Great Deals out of 35,116 listings starting at $1,250
Used Ford Bronco
207 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.