What. Makes ac blower relay keep going bad ie high speed connection. Getting hot and not working. ..

Asked by Jul 25, 2014 at 11:05 AM about the 1994 Chevrolet S-10 Blazer

Question type: Maintenance & Repair

Replaced resistor other speeds started.
Working replaced relay high worked. Then
stopped...after a week...

1 Answer

96,925

Excessive motor amperage draw on start up. I had a Buick doing the same thing, I went through 2 relays within a week, replaced the blower motor and problem went away.

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Blazer Questions

Chevrolet S-10 Blazer Experts

#1 carGrrl
carGrrl
Reputation 1,510
#2 Cody Doud
Cody Doud
Reputation 620
#3 emtfirefighter77
emtfirefighter77
Reputation 330
View All

Related Models For Sale

Used Chevrolet Blazer
1,169 listings starting at $1,495
Used Chevrolet S-10
6 Great Deals out of 1,332 listings starting at $1,999
Used Chevrolet Tahoe
582 Great Deals out of 33,058 listings starting at $1,500
Used Ford F-150
2,150 Great Deals out of 193,915 listings starting at $290
Used Chevrolet Camaro
354 Great Deals out of 31,417 listings starting at $2,400
Used Ford Mustang
696 Great Deals out of 44,783 listings starting at $1,500
Used Jeep Cherokee
379 Great Deals out of 40,642 listings starting at $1,500
Used Chevrolet Corvette
221 Great Deals out of 22,190 listings starting at $3,850
Used Toyota 4Runner
234 Great Deals out of 19,524 listings starting at $1,500
Used Chevrolet Impala
600 Great Deals out of 35,644 listings starting at $899
Used Dodge Ram 1500
419 Great Deals out of 10,970 listings starting at $1,000
Used Chevrolet Monte Carlo
12 Great Deals out of 1,427 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.