I have a 94 Cheyenne with a 4.3 v6. The heads we just redid and as we hooked battery back up the truck runs great. Except the brake lights only work when key is off. When on cruise and wipers dont wor

Asked by Dec 05, 2014 at 02:09 AM about the 1994 Chevrolet C/K 1500

Question type: Maintenance & Repair

We have replaced every sensor on
engine...but since new battery the
brake lights cruise and wipers dont
work when running

2 Answers


Check the fuses.

We did check the fuses. Still not it. It has to be something simple. Everything worked fine before heads and pushrods were put in. No one messed with electrical.

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
  • #2
    John Saffrahn
  • #3
View All

Related Models For Sale

Used GMC Sierra 1500
877 Great Deals out of 59,609 listings starting at $1,980
Used Ford F-150
2,521 Great Deals out of 220,358 listings starting at $1,222
Used Chevrolet C/K 2500
189 listings starting at $3,495
Used Dodge Ram 1500
336 Great Deals out of 9,586 listings starting at $800
Used Chevrolet Tahoe
590 Great Deals out of 37,467 listings starting at $1,699
Used Chevrolet Camaro
236 Great Deals out of 30,155 listings starting at $4,980
Used Toyota Tacoma
427 Great Deals out of 42,057 listings starting at $2,600
Used Chevrolet C/K 3500
175 listings starting at $6,990
Used Chevrolet S-10
8 Great Deals out of 995 listings starting at $999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.