I have a 94 Cheyenne with a 4.3 v6. The heads we just redid and as we hooked battery back up the truck runs great. Except the brake lights only work when key is off. When on cruise and wipers dont wor

Asked by Dec 05, 2014 at 02:09 AM about the 1994 Chevrolet C/K 1500

Question type: Maintenance & Repair

We have replaced every sensor on
engine...but since new battery the
brake lights cruise and wipers dont
work when running

2 Answers

1,760

Check the fuses.

We did check the fuses. Still not it. It has to be something simple. Everything worked fine before heads and pushrods were put in. No one messed with electrical.

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 3,480
#2 John Saffrahn
John Saffrahn
Reputation 2,530
#3 Rowefast
Rowefast
Reputation 2,110
View All

Related Models For Sale

Used GMC Sierra 1500
774 Great Deals out of 68,507 listings starting at $1,800
Used Ford F-150
2,127 Great Deals out of 193,349 listings starting at $290
Used Chevrolet C/K 2500
208 listings starting at $6,499
Used Dodge Ram 1500
403 Great Deals out of 10,928 listings starting at $1,000
Used Chevrolet Tahoe
584 Great Deals out of 32,918 listings starting at $1,500
Used Toyota Tacoma
531 Great Deals out of 42,958 listings starting at $1,995
Used Chevrolet Camaro
354 Great Deals out of 31,326 listings starting at $2,200
Used Chevrolet S-10
7 Great Deals out of 1,334 listings starting at $1,999
Used Chevrolet C/K 3500
232 listings starting at $2,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.