I have a 95 S10 and when i try to start it i have the clutch pushed in and it clicks but my battery is good and i just replaced my starter.

Asked by Jan 28, 2016 at 10:19 AM about the 1995 Chevrolet S-10

Question type: Maintenance & Repair

1 Answer

58,235

Sounds like some bad connections or possibly bad battery cables.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,240
#2 Trebor66
Trebor66
Reputation 950
#3 John Saffrahn
John Saffrahn
Reputation 940
View All

Related Models For Sale

Used Ford Ranger
178 Great Deals out of 6,234 listings starting at $1,300
Used GMC Sonoma
3 Great Deals out of 473 listings starting at $2,700
Used Toyota Tacoma
522 Great Deals out of 37,570 listings starting at $2,950
Used Ford F-150
2,424 Great Deals out of 210,079 listings starting at $895
Used Dodge Dakota
105 Great Deals out of 3,905 listings starting at $1,500
Used Chevrolet Blazer
1,141 listings starting at $1,995
Used GMC Sierra 1500
861 Great Deals out of 64,419 listings starting at $1,500
Used Dodge Ram 1500
438 Great Deals out of 11,486 listings starting at $700
Used Chevrolet C/K 1500
878 listings starting at $2,500
Used Chevrolet Camaro
133 Great Deals out of 35,344 listings starting at $1,995
Used Chevrolet Tahoe
607 Great Deals out of 27,648 listings starting at $600

Used Cars For Sale

2004 Chevrolet S-10 For Sale
55 listings starting at $2,999
2003 Chevrolet S-10 For Sale
350 listings starting at $2,895
2002 Chevrolet S-10 For Sale
219 listings starting at $1,995
2000 Chevrolet S-10 For Sale
206 listings starting at $4,855