I have a 95 S10 and when i try to start it i have the clutch pushed in and it clicks but my battery is good and i just replaced my starter.

Asked by Jan 28, 2016 at 10:19 AM about the 1995 Chevrolet S-10

Question type: Maintenance & Repair

1 Answer

83,965

Sounds like some bad connections or possibly bad battery cables.

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,810
  • #2
    John Saffrahn
    Reputation
    1,110
  • #3
    Trebor66
    Reputation
    1,090
View All

Related Models For Sale

Used Ford Ranger
119 Great Deals out of 4,407 listings starting at $1,295
Used Toyota Tacoma
432 Great Deals out of 48,711 listings starting at $2,994
Used GMC Sonoma
280 listings starting at $2,150
Used Ford F-150
2,415 Great Deals out of 207,419 listings starting at $1,300
Used Dodge Dakota
84 Great Deals out of 3,087 listings starting at $1,495
Used Chevrolet Blazer
705 listings starting at $900
Used GMC Sierra 1500
749 Great Deals out of 61,489 listings starting at $1,395
Used Dodge Ram 1500
323 Great Deals out of 9,370 listings starting at $1,995
Used Chevrolet Camaro
240 Great Deals out of 27,310 listings starting at $2,077
Used Chevrolet C/K 1500
696 listings starting at $2,200
Used Ford Mustang
256 Great Deals out of 38,496 listings starting at $1,350

Used Cars For Sale

2004 Chevrolet S-10 For Sale
29 listings starting at $3,995
2003 Chevrolet S-10 For Sale
3 Great Deals out of 205 listings starting at $2,650
2002 Chevrolet S-10 For Sale
149 listings starting at $3,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.