No power Running to my engine

Asked by Apr 19, 2017 at 09:18 PM about the 1996 Chevrolet C/K 2500

Question type: Maintenance & Repair

I have a 96 Chevy C2500. I have already replaced
the battery, fuel pump, gaskets,spark plugs, egm ,
checked fuses, complete tune up. I finally got it
running but when I drive it and accelerate, it doesn't
seem to accelerate as much as it should. Any
ideas on what this might be??

2 Answers

31,725

i dont see fuel filter and or pressure at the intake.... or cat.. .converter pressure in and out of that also ,....in your list

1 people found this helpful.

@Kelly, yes those have been checked and replaced also. And there was a typo in my list. It's not EGM it's the EGR Valve that I replaced last. I can't figure out what it could be.

Your Answer:

Chevrolet C/K 2500 Experts

  • #1
    Rowefast
    Reputation
    340
  • #2
    COMETGUY61
    Reputation
    220
  • #3
    Andrew Olsen
    Reputation
    150
View All

Related Models For Sale

Used Chevrolet C/K 3500
197 listings starting at $3,500
Used Chevrolet C/K 1500
718 listings starting at $800
Used Dodge Ram 2500
131 Great Deals out of 4,723 listings starting at $999
Used GMC Sierra 2500
112 listings starting at $5,999
Used Ford F-250
395 listings starting at $3,495
Used Ford F-150
2,357 Great Deals out of 199,530 listings starting at $1,300

Used Cars For Sale

2000 Chevrolet C/K 2500 For Sale
26 listings starting at $5,995
1997 Chevrolet C/K 2500 For Sale
19 listings starting at $3,950

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.