No power Running to my engine

Asked by Apr 19, 2017 at 09:18 PM about the 1996 Chevrolet C/K 2500

Question type: Maintenance & Repair

I have a 96 Chevy C2500. I have already replaced
the battery, fuel pump, gaskets,spark plugs, egm ,
checked fuses, complete tune up. I finally got it
running but when I drive it and accelerate, it doesn't
seem to accelerate as much as it should. Any
ideas on what this might be??

2 Answers

28,065

i dont see fuel filter and or pressure at the intake.... or cat.. .converter pressure in and out of that also ,....in your list

1 of 1 people found this helpful.

@Kelly, yes those have been checked and replaced also. And there was a typo in my list. It's not EGM it's the EGR Valve that I replaced last. I can't figure out what it could be.

Your Answer

Chevrolet C/K 2500 Experts

  • #1
    Rowefast
    Reputation
    310
  • #2
    COMETGUY61
    Reputation
    190
  • #3
    Andrew Olsen
    Reputation
    150
View All

Related Models For Sale

Used Chevrolet C/K 3500
207 listings starting at $3,199
Used Chevrolet C/K 1500
853 listings starting at $2,603
Used Dodge Ram 2500
145 Great Deals out of 5,449 listings starting at $2,661
Used GMC Sierra 2500
156 listings starting at $5,795
Used Ford F-250
447 listings starting at $4,995
Used Ford F-150
3,216 Great Deals out of 220,430 listings starting at $1,200
Used GMC Sierra 1500
1,223 Great Deals out of 64,512 listings starting at $999

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.