temperature gauge will not move upon start up and after about ten minutes of running still does not move . engine not overheating coolant is good no leaks was workin fine up to three days ago.

Asked by Jun 27, 2015 at 12:53 PM about the 2001 Pontiac Montana

Question type: Maintenance & Repair

1 Answer

1,655

Temp sensor could be bad.

Your Answer

Pontiac Montana Experts

  • #1
    Countrygal77
    Reputation
    2,120
  • #2
    Robert Reed
    Reputation
    1,530
  • #3
    Jim Space
    Reputation
    780
View All

Related Models For Sale

Used Chevrolet Venture
372 listings starting at $2,190
Used Chrysler Town & Country
269 Great Deals out of 13,979 listings starting at $1,999
Used Dodge Grand Caravan
274 Great Deals out of 25,764 listings starting at $1,500
Used Honda Odyssey
402 Great Deals out of 27,636 listings starting at $1,899
Used Oldsmobile Silhouette
141 listings starting at $3,995
Used Toyota Sienna
373 Great Deals out of 26,513 listings starting at $1,799
Used Chevrolet Impala
534 Great Deals out of 35,073 listings starting at $800
Used Chevrolet Silverado 1500
2,221 Great Deals out of 168,149 listings starting at $1,000
Used Toyota Camry
880 Great Deals out of 81,517 listings starting at $999
Used Honda Civic
742 Great Deals out of 68,804 listings starting at $1,350

Used Cars For Sale

2001 Pontiac Montana For Sale
40 listings starting at $2,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.