temperature gauge will not move upon start up and after about ten minutes of running still does not move . engine not overheating coolant is good no leaks was workin fine up to three days ago.

Asked by Jun 27, 2015 at 12:53 PM about the 2001 Pontiac Montana

Question type: Maintenance & Repair

1 Answer

1,565

Temp sensor could be bad.

Your Answer

Add photo

Related Questions

Search Pontiac Montana Questions

Pontiac Montana Experts

#1 Countrygal77
Countrygal77
Reputation 2,020
#2 Robert Reed
Robert Reed
Reputation 1,440
#3 Jim Space
Jim Space
Reputation 750
View All

Related Models For Sale

Used Toyota Sienna
224 Great Deals out of 29,669 listings starting at $1,495
Used Honda Odyssey
213 Great Deals out of 20,911 listings starting at $1,900
Used Chevrolet Venture
430 listings starting at $1,699
Used Dodge Grand Caravan
167 Great Deals out of 26,541 listings starting at $2,300
Used Chrysler Town & Country
273 Great Deals out of 16,152 listings starting at $900
Used Dodge Caravan
667 listings
Used Nissan Quest
64 Great Deals out of 2,760 listings starting at $2,499
Used Pontiac Grand Am
1,183 listings starting at $1,599
Used Nissan Pathfinder
281 Great Deals out of 22,990 listings starting at $1,499
Used Chevrolet Tahoe
559 Great Deals out of 31,371 listings starting at $1,500
Used Chevrolet Malibu
1,060 Great Deals out of 77,910 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.