i have a 2003 motana all conections are good stil have no power

Asked by Sep 29, 2015 at 07:38 PM about the 2003 Pontiac Montana

Question type: Maintenance & Repair

1 Answer

125

There may be a large blade fuse failed under the hood. 40 or 50 amp.

Your Answer

Add photo

Related Questions

Search Pontiac Montana Questions

Pontiac Montana Experts

#1 Countrygal77
Countrygal77
Reputation 1,980
#2 Robert Reed
Robert Reed
Reputation 1,410
#3 Jim Space
Jim Space
Reputation 730
View All

Related Models For Sale

Used Dodge Grand Caravan
292 Great Deals out of 29,032 listings starting at $1,850
Used Chevrolet Venture
442 listings starting at $1,800
Used Honda Odyssey
227 Great Deals out of 23,250 listings starting at $1,995
Used Pontiac Grand Prix
26 Great Deals out of 2,869 listings starting at $1,477
Used Chrysler Town & Country
319 Great Deals out of 16,997 listings starting at $1,600
Used GMC Sierra 1500
796 Great Deals out of 67,648 listings starting at $1,995
Used Pontiac Bonneville
4 Great Deals out of 529 listings starting at $1,799
Used Dodge Caravan
682 listings
Used Toyota Sienna
235 Great Deals out of 28,967 listings starting at $1,648
Used Chevrolet Impala
557 Great Deals out of 30,772 listings starting at $799
Used Toyota Corolla
736 Great Deals out of 71,823 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.