Hello, I do not have oil pressure. I have a 98 4.3l crate motor ,new oil pump,and screen. I have changed the sensor 2 times and have installed a different gauge also and still no pressure.

Asked by Apr 26, 2015 at 03:35 AM about the 1998 Oldsmobile Bravada

Question type: Maintenance & Repair

2 Answers

113,585

Have you checked for a break in the wire going to the gauge?

1 of 1 people found this helpful.
105,465

Are you sure that the new pump is working? I would install a manual gauge temporally just to make sure you have proper pressure, and if you don't then find out why the pump failed, if you do then you know it is oil pressure gauge circuits and not an oil pressure problem.

Your Answer

Oldsmobile Bravada Experts

  • #1
    Tom Demyan
    Reputation
    70
  • #2
    Js08016
    Reputation
    60
  • #3
    T_S_T
    Reputation
    50
View All

Related Models For Sale

Used Chevrolet Blazer
6 Great Deals out of 931 listings starting at $950
Used GMC Envoy
41 Great Deals out of 1,978 listings starting at $1,499
Used Jeep Grand Cherokee
1,080 Great Deals out of 72,501 listings starting at $1,195
Used GMC Jimmy
205 listings starting at $2,500
Used Chevrolet Silverado 1500
2,703 Great Deals out of 174,507 listings starting at $955
Used Oldsmobile Alero
389 listings starting at $1,500
Used Chevrolet S-10
12 Great Deals out of 1,215 listings starting at $1,550
Used Chevrolet Suburban
487 Great Deals out of 24,242 listings starting at $1,799
Used Honda CR-V
903 Great Deals out of 59,692 listings starting at $1,495
Used Mercedes-Benz C-Class
900 Great Deals out of 28,312 listings starting at $2,001

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.