Hello, I do not have oil pressure. I have a 98 4.3l crate motor ,new oil pump,and screen. I have changed the sensor 2 times and have installed a different gauge also and still no pressure.

Asked by Apr 26, 2015 at 03:35 AM about the 1998 Oldsmobile Bravada

Question type: Maintenance & Repair

2 Answers

104,205

Have you checked for a break in the wire going to the gauge?

1 of 1 people found this helpful.
95,095

Are you sure that the new pump is working? I would install a manual gauge temporally just to make sure you have proper pressure, and if you don't then find out why the pump failed, if you do then you know it is oil pressure gauge circuits and not an oil pressure problem.

Your Answer

Add photo

Related Questions

Search Oldsmobile Bravada Questions

Oldsmobile Bravada Experts

#1 Js08016
Js08016
Reputation 60
#1 Tom Demyan
Tom Demyan
Reputation 60
#3 T_S_T
T_S_T
Reputation 50
View All

Related Models For Sale

Used Chevrolet Blazer
3 Great Deals out of 1,189 listings starting at $1,820
Used GMC Jimmy
274 listings starting at $2,495
Used Ford Explorer
926 Great Deals out of 70,243 listings starting at $997
Used Dodge Ram 1500
411 Great Deals out of 10,835 listings starting at $1,400
Used GMC Yukon
379 Great Deals out of 19,293 listings starting at $2,000
Used GMC Envoy
61 Great Deals out of 2,161 listings starting at $850
Used Chevrolet Tahoe
556 Great Deals out of 31,361 listings starting at $1,500
Used Chevrolet S-10
5 Great Deals out of 1,311 listings starting at $2,400
Used Oldsmobile Alero
467 listings starting at $795
Used Jeep Grand Cherokee
1,014 Great Deals out of 72,235 listings starting at $700

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.