My radio has no sound all lights and buttons work but no sound ??????

Asked by Jul 16, 2014 at 02:45 AM about the 2001 Oldsmobile Alero

Question type: Maintenance & Repair

Was driving and all of a sudden my radio went mute and no sound every since all light
and buttons working just no sound help please

2 Answers

65

check the radio amp, Its in the trunk on the driver side. Or is the amp plug may have come unpluged

2 of 2 people found this helpful.

I have a 2004 Oldsmobile Alero and when you turn the radio on it barely has sound but when you turn car off it makes a high pitched squealing sound what's the problem please help

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    610
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Nir Eliyaho
    Reputation
    210
View All

Related Models For Sale

Used Chevrolet Malibu
1,009 Great Deals out of 53,822 listings starting at $1,250
Used Oldsmobile Aurora
109 listings
Used Oldsmobile Intrigue
148 listings starting at $900
Used Ford Mustang
343 Great Deals out of 42,031 listings starting at $1,488
Used Toyota Camry
1,107 Great Deals out of 76,352 listings starting at $1,100
Used Nissan Maxima
325 Great Deals out of 20,535 listings starting at $1,175
Used Pontiac Grand Am
952 listings
Used Honda Accord
858 Great Deals out of 87,669 listings starting at $1,444
Used Pontiac Grand Prix
12 Great Deals out of 2,455 listings starting at $1,900
Used Honda Accord Coupe
142 Great Deals out of 5,071 listings starting at $2,000
Used Chrysler Sebring
15 Great Deals out of 2,585 listings starting at $1,495
Used Chevrolet Camaro
378 Great Deals out of 31,278 listings starting at $3,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.