I have a 2004 Olds Alero. While driving to work this morning, the engine started reving but no acceleration. I pulled over to the side of the road, put it in neutral and then park and then drive again, and again, the engine would rev but would not move forward. It will reverse but will not move forward. What could the problem be?

Asked by Jun 10, 2016 at 10:59 AM about the 2004 Oldsmobile Alero

Question type: Maintenance & Repair

1 Answer

286,175

Sounds transmission related. It's not engaging? A low fluid level sometimes causes this issue. Are you leaking fluid? Also could be an internal failure or solenoid issue. Best to have the pros check it out.

Your Answer

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    610
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Nir Eliyaho
    Reputation
    210
View All

Related Models For Sale

Used Chevrolet Malibu
461 Great Deals out of 50,033 listings starting at $2,000
Used Oldsmobile Bravada
139 listings starting at $1,999
Used Honda Civic
354 Great Deals out of 53,556 listings starting at $1,200
Used Chevrolet Impala
399 Great Deals out of 25,796 listings starting at $900
Used Honda Accord
456 Great Deals out of 102,475 listings starting at $990
Used Pontiac Grand Prix
5 Great Deals out of 1,790 listings starting at $2,008
Used Toyota Camry
766 Great Deals out of 71,853 listings starting at $1,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.