I have a 2004 Olds Alero. While driving to work this morning, the engine started reving but no acceleration. I pulled over to the side of the road, put it in neutral and then park and then drive again, and again, the engine would rev but would not move forward. It will reverse but will not move forward. What could the problem be?

Asked by Jun 10, 2016 at 10:59 AM about the 2004 Oldsmobile Alero

Question type: Maintenance & Repair

1 Answer

299,285

Sounds transmission related. It's not engaging? A low fluid level sometimes causes this issue. Are you leaking fluid? Also could be an internal failure or solenoid issue. Best to have the pros check it out.

Your Answer:

Oldsmobile Alero Experts

  • #1
    sun4shine2006
    Reputation
    620
  • #2
    Chris Kelso
    Reputation
    260
  • #3
    Rowefast
    Reputation
    220
View All

Related Models For Sale

Used Chevrolet Malibu
621 Great Deals out of 50,838 listings starting at $600
Used Pontiac G6
45 Great Deals out of 2,699 listings starting at $750
Used Chevrolet Impala
510 Great Deals out of 26,020 listings starting at $995
Used Chevrolet Tahoe
655 Great Deals out of 38,141 listings starting at $1,199
Used Honda Accord
686 Great Deals out of 101,993 listings starting at $999
Used Toyota Camry
859 Great Deals out of 70,688 listings starting at $1,000
Used Chevrolet Corvette
79 Great Deals out of 15,067 listings starting at $3,700
Used Ford Mustang
297 Great Deals out of 39,759 listings starting at $1,312
Used Pontiac Grand Prix
15 Great Deals out of 1,695 listings starting at $1,500
Used Oldsmobile Bravada
146 listings starting at $2,950

Used Cars For Sale

2001 Oldsmobile Alero For Sale
47 listings starting at $900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.