I have a 93 capri that no oil pressure when hot at idle running just fine no knocks it has been like this for 7 years the prev. owner said any help

Asked by Jun 26, 2014 at 07:18 PM about the 1993 Mercury Capri

Question type: Maintenance & Repair

2 Answers


Could be a bad oil pressure relief valve. The spring is probably weak from age and letting oil pass through when it shouldn't. My Father's '73 Ford LTD had the same issue. He had the relief valve replaced and it was fine after that. HTH. -Jim


Check the sender for the oil pressure.

Your Answer

Mercury Capri Experts

  • #1
  • #2
  • #3
View All

Related Models For Sale

Used Ford Mustang
291 Great Deals out of 38,369 listings starting at $1,995
Used Ford Mustang SVT Cobra
7 Great Deals out of 257 listings starting at $3,000
Used Mercury Cougar
157 listings
Used Toyota Celica
5 Great Deals out of 242 listings starting at $1,995
Used Pontiac Firebird
8 Great Deals out of 672 listings starting at $2,500
Used Ford F-150
2,558 Great Deals out of 220,223 listings starting at $1,222
Used Buick Regal
108 Great Deals out of 4,193 listings starting at $3,500
Used Chevrolet Camaro
242 Great Deals out of 30,118 listings starting at $4,980
Used Chevrolet Corvette
86 Great Deals out of 15,794 listings starting at $4,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.