I have a 93 capri that no oil pressure when hot at idle running just fine no knocks it has been like this for 7 years the prev. owner said any help

Asked by Jun 26, 2014 at 07:18 PM about the 1993 Mercury Capri

Question type: Maintenance & Repair

2 Answers

67,505

Could be a bad oil pressure relief valve. The spring is probably weak from age and letting oil pass through when it shouldn't. My Father's '73 Ford LTD had the same issue. He had the relief valve replaced and it was fine after that. HTH. -Jim

30

Check the sender for the oil pressure.

Your Answer

Add photo

Related Questions

Search Mercury Capri Questions

Mercury Capri Experts

#1 jogger
jogger
Reputation 270
#2 tuff4x4
tuff4x4
Reputation 190
#3 dandyoun
dandyoun
Reputation 110
View All

Related Models For Sale

Used Ford Mustang
637 Great Deals out of 46,709 listings starting at $750
Used Mercury Cougar
200 listings
Used Chevrolet Camaro
246 Great Deals out of 31,906 listings starting at $1,000
Used Chevrolet Caprice
165 listings starting at $9,900
Used Ford Thunderbird
22 Great Deals out of 1,075 listings starting at $6,995
Used Mercury Grand Marquis
25 Great Deals out of 1,848 listings starting at $2,000
Used Lincoln Continental
6 Great Deals out of 5,178 listings starting at $37,988
Used Pontiac Firebird
11 Great Deals out of 773 listings starting at $3,490
Used BMW 3 Series
964 Great Deals out of 30,761 listings starting at $1,000
Used Mazda MX-5 Miata
63 Great Deals out of 3,926 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.