1972 chevy c10 temp gauge not working. i replaced sending unit and gauge needle does peg when grounded

Asked by Oct 25, 2013 at 05:29 PM about the 1972 Chevrolet C/K 10

Question type: General

2 Answers

7,025

Did you put in the correct temp sender, (80 - 120 vs 120 - 220) ? It is not uncommon for even "new" senders to be broken from the factory. I would tell you to verify the temp range required and buy another new unit. Did you recheck the sender wire for any damage or chaffing of the wire covering from sender to gauge ?

67,445

Did the auto parts store give you the correct sending unit? The one for the gauge is a variable resistor to ground. The one for the light is an on/off switch. HTH. -Jim

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 10 Questions

Chevrolet C/K 10 Experts

#1 CaptPKelly
CaptPKelly
Reputation 660
#2 Rowefast
Rowefast
Reputation 370
#3 F_O_R
F_O_R
Reputation 330
View All

Related Models For Sale

Used Chevrolet Camaro
245 Great Deals out of 31,195 listings starting at $369
Used Ford F-100
146 listings
Used Chevrolet Corvette
147 Great Deals out of 20,685 listings starting at $3,995
Used Ford Mustang
537 Great Deals out of 45,845 listings starting at $1,999
Used Ford Bronco
203 listings
Used Chevrolet Blazer
3 Great Deals out of 1,188 listings starting at $1,820

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.