All my electronics are off but the car starts.

Asked by Oct 06, 2016 at 01:17 PM about the 1996 Lexus LS 400

Question type: Maintenance & Repair

I had a battery drain when the car is parked, I would remove a terminal
whenever I park the car. Now the electronics have completely shut off but the
car runs when start the ignition. Please help. I suspect it's my alternator but
I'm not sure.

2 Answers

140

It has nothing to do with your alternator. Your alternator just charges your battery. You must have some short somewhere and that could be serious. You need to have the car inspected immediately, it could be only time before it could die on you completely or worst catch on fire. Take care of it immediately for your own safety.

103,865

Try this first/ https://www.youtube.com/watch?v=9wLrTjeb9TY

Your Answer

Add photo

Related Questions

Search Lexus LS 400 Questions

Lexus LS 400 Experts

#1 Tom Demyan
Tom Demyan
Reputation 470
#2 dandyoun
dandyoun
Reputation 220
#3 Sam Lee
Sam Lee
Reputation 180
View All

Related Models For Sale

Used Lexus GS 300
28 Great Deals out of 758 listings starting at $2,700
Used BMW 7 Series
164 Great Deals out of 5,957 listings starting at $2,999
Used Lexus ES 300
11 Great Deals out of 900 listings starting at $1,495
Used Toyota Camry
1,103 Great Deals out of 90,763 listings starting at $1,599
Used Mercedes-Benz S-Class
141 Great Deals out of 6,601 listings starting at $2,990
Used Mercedes-Benz E-Class
361 Great Deals out of 19,348 listings starting at $1,500
Used BMW 5 Series
470 Great Deals out of 15,436 listings starting at $500
Used Honda Accord
947 Great Deals out of 77,741 listings starting at $899
Used BMW 3 Series
945 Great Deals out of 30,260 listings starting at $1,000
Used Lexus SC 400
71 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.