All my electronics are off but the car starts.

Tshidiso LeChuba

Asked by Oct 06, 2016 at 01:17 PM about the 1996 Lexus LS 400

Question type: Maintenance & Repair

I had a battery drain when the car is parked, I would remove a terminal
whenever I park the car. Now the electronics have completely shut off but the
car runs when start the ignition. Please help. I suspect it's my alternator but
I'm not sure.

2 Answers


It has nothing to do with your alternator. Your alternator just charges your battery. You must have some short somewhere and that could be serious. You need to have the car inspected immediately, it could be only time before it could die on you completely or worst catch on fire. Take care of it immediately for your own safety.


Try this first/

Your Answer

Add photo

Related Questions

Search Lexus LS 400 Questions

Lexus LS 400 Experts

#1 Tom Demyan
Tom Demyan
Reputation 370
#2 FordNut
Reputation 340
#3 dandyoun
Reputation 210
View All

Related Models For Sale

Used Lexus GS 300"
24 Great Deals out of 997 listings starting at $3,200
Used Lexus ES 300"
11 Great Deals out of 1,159 listings starting at $1,500
Used Lexus SC 400"
87 listings starting at $3,000
Used Honda Accord"
1,263 Great Deals out of 78,694 listings starting at $1,400
Used BMW 7 Series"
193 Great Deals out of 5,865 listings starting at $2,995
Used Toyota Camry"
1,608 Great Deals out of 98,371 listings starting at $895
Used Mercedes-Benz S-Class"
174 Great Deals out of 6,641 listings starting at $1,899

Used Cars For Sale

1999 Lexus LS 400 For Sale
3 Great Deals out of 36 listings starting at $2,995
1997 Lexus LS 400 For Sale
40 listings starting at $5,995