no ac..heater

Asked by May 13, 2013 at 06:44 AM about the 1999 Lexus SC 300

Question type: General

the display went out on the control. No heat, ac, rear, front defroster. Also no display on mpg,outside temp. Has the unit gone bad? Display still lights up but no information. Basically no climate control.

2 Answers

190

check your fuses first

2 of 2 people found this helpful.

Did check fuses but must have read manual wrong. Went back and checked again and was a blown 15 amp fuse not the 10 amp I was checking. Was an oversight on my part. Thank you very much for your quick response to my question. My SC300 is a 1999 with 150,000 miles. beautiful car and fun to drive. Only 3 months as an owner. Thanks again.

Your Answer

Lexus SC 300 Experts

  • #1
    Lee Winters
    Reputation
    180
  • #2
    casper271
    Reputation
    130
  • #3
    cheriwalker65
    Reputation
    110
View All

Related Models For Sale

Used Lexus SC 400
58 listings
Used Toyota Supra
68 listings
Used Nissan 240SX
11 listings
Used Lexus GS 300
25 Great Deals out of 699 listings starting at $1,900
Used BMW 3 Series
1,166 Great Deals out of 33,304 listings starting at $1,000
Used BMW M3
46 Great Deals out of 1,811 listings starting at $5,995
Used Mazda RX-7
71 listings
Used Mazda MX-5 Miata
80 Great Deals out of 4,431 listings starting at $2,200
Used Chevrolet Camaro
416 Great Deals out of 30,919 listings starting at $3,550

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.