no ac..heater


Asked by May 13, 2013 at 06:44 AM about the 1999 Lexus SC 300

Question type: General

the display went out on the control. No heat, ac, rear, front defroster. Also no display on mpg,outside temp. Has the unit gone bad? Display still lights up but no information. Basically no climate control.

2 Answers


check your fuses first

2 of 2 people found this helpful.

Did check fuses but must have read manual wrong. Went back and checked again and was a blown 15 amp fuse not the 10 amp I was checking. Was an oversight on my part. Thank you very much for your quick response to my question. My SC300 is a 1999 with 150,000 miles. beautiful car and fun to drive. Only 3 months as an owner. Thanks again.

1 of 1 people found this helpful.

Your Answer

Lexus SC 300 Experts

  • #1
    Lee Winters
  • #2
  • #3
View All

Related Models For Sale

Used Lexus SC 400
48 listings
Used Lexus GS 300
11 Great Deals out of 576 listings starting at $2,799
Used Toyota Supra
54 listings
Used Ford Mustang
287 Great Deals out of 38,472 listings starting at $1,995
Used Nissan 240SX
11 listings
Used BMW 3 Series
900 Great Deals out of 32,980 listings starting at $1,300
Used Honda Civic
374 Great Deals out of 51,346 listings starting at $1,200
Used Acura Integra
86 listings starting at $2,495
Used Chevrolet Camaro
245 Great Deals out of 30,155 listings starting at $4,980

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.