Good Day Hope someone can assist. Both my temperature sensor and thermostat on my 1400 Opel Cora Sport (2006 model), was changed earlier this week. But i am still having the same problem. My temperature gauge in my car, shows that the temp. is running on 80, but when switch of the car, let it stand for a few seconds, and turn it on again, the reading is 90, Then it drops when you start to drive again Both my Thermostat and Temperature sensors was changed, but with no luck Any idea on what it can be?

Asked by Nov 24, 2016 at 09:19 AM about the 2006 Opel GT

Question type: Maintenance & Repair

Good Day
Hope someone can assist. Both my temperature sensor and thermostat on
my 1400 Opel Cora Sport (2006 model), was changed earlier this week. But i
am still having the same problem.
My temperature gauge in my car, shows that the temp. is running on 80, but
when switch of the car, let it stand for a few seconds, and turn it on again,
the reading is 90, Then it drops when you start to drive again
Both my Thermostat and Temperature sensors was changed, but with no
luck
Any idea on what it can be?

1 Answer

254,585

Could be a faulty gauge, but most stock gauges are inaccurate. As long as you have heat in the car and your not overheating the engine, you should be fine.

1 of 1 people found this helpful.

Your Answer

Opel GT Experts

  • #1
    Tom Demyan
    Reputation
    10
View All

Related Models For Sale

Used Saturn Sky
13 Great Deals out of 184 listings starting at $5,888
Used Ford Mustang
725 Great Deals out of 38,098 listings starting at $895

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.