Problem with car holding idle at startup. I manually hold accelerator to warm engine. Then engine may sputter and miss until car hits 2nd gear and runs for a minute. Then car drives fine.

Asked by Nov 05, 2011 at 08:17 AM about the 1989 Chevrolet Celebrity

Question type: Maintenance & Repair

After stopping I may have to wait an hour for the car to start again.  Acts like a computer chip problem.  Really perplexed!

2 Answers

clean or replace egr valve and check for vacume leaks.

Check coolant level in radiator...not just in overflow bottle. If it's low, fill and try again. Also, unplug coolant temperature sensor, usually located near thermostat housing. (follow top radiator hose to where it meets engine) See if it runs better cold and/or starts when its hot. If either is true when unplugged, replace sensor.

Your Answer

Add photo

Related Questions

Search Chevrolet Celebrity Questions

Chevrolet Celebrity Experts

#1 Rowefast
Rowefast
Reputation 70
#2 tennisshoes
tennisshoes
Reputation 50
#3 mlewis33
mlewis33
Reputation 40
View All

Related Models For Sale

Used Chevrolet Cavalier
1,073 listings
Used Mercury Grand Marquis
20 Great Deals out of 1,837 listings starting at $1,600
Used Chevrolet Monte Carlo
12 Great Deals out of 1,407 listings starting at $1,995
Used Buick Regal
118 Great Deals out of 10,253 listings starting at $3,495
Used Chevrolet Camaro
145 Great Deals out of 32,807 listings starting at $1,995
Used Chevrolet Caprice
151 listings starting at $10,490
Used Buick Century
891 listings starting at $1,250