stops running after car warms up

Asked by Sep 03, 2009 at 07:10 AM about the 1989 Chevrolet Celebrity

Question type: Maintenance & Repair

  I seem to have a problemm that after I start car and take off after a few miles it will start to stall and go dead and will act like it wants to start back up but will not untill it cools back down ( already changed fuel filter ) anybody got a clue  Thanks Bruce

5 Answers

i have the same problem with my 85,and after checking the net,it seems like an ongoing problem for alot of celeb owners. all with no explanation on how to solve the problem....good luck !

It's likely the fuel injector(s). replaced them and it fixed problem.

10

I had the same thing happen. It was the crank shaft position sensor.

Crank sensor...common problem!

possibly bad coil pack. It is right under the front exhaust manifold.

Your Answer

Add photo

Related Questions

Celebrity

Looking for a Used Celebrity in your area?

CarGurus has 4 nationwide Celebrity listings and the tools to find you a great deal.

ZIP:

Search Chevrolet Celebrity Questions

Chevrolet Celebrity Experts

#1 tennisshoes
tennisshoes
Reputation 70
#1 Rowefast
Rowefast
Reputation 70
#3 F_O_R
F_O_R
Reputation 50
View All

Related Models For Sale

Used Buick Century
859 listings starting at $2,300
Used Buick Regal
160 Great Deals out of 10,573 listings starting at $4,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.