00 Windstar Rough Idle and Run, both in and out of gear

5

Asked by Nov 23, 2011 at 02:08 AM about the 2000 Ford Windstar

Question type: Maintenance & Repair

I have a 2000 Windstar that has a very rough engine at idle, running at all speeds, in gear and in neutral. It acts as if a spark plug wire has been disconnected as far as behavior. There is no trouble code that would explain it and the check engine light is NOT on. I had a Ford dealer look at it and they said everything with the engine is fine. The front wheels jerk or vibrate when it is running, both in and out of gear. The dealer's mechanic said it could be the torque converter, a transmission problem or a camshaft balancer in the engine that they said they have never seen go bad. The transmission fluid looks fine, and does not smell burnt.

1 Answer

bad egr or IAC-idle air control.

3 of 3 people found this helpful.

Your Answer

Ford Windstar Experts

  • #1
    JohnBarJB
    Reputation
    570
  • #2
    T_S_T
    Reputation
    460
  • #3
    Tom Demyan
    Reputation
    410
View All

Related Models For Sale

Used Chrysler Town & Country
269 Great Deals out of 14,086 listings starting at $1,999
Used Dodge Grand Caravan
280 Great Deals out of 26,094 listings starting at $2,795
Used Honda Odyssey
414 Great Deals out of 27,295 listings starting at $1,850
Used Ford F-150
2,575 Great Deals out of 197,079 listings starting at $1,300
Used Toyota Sienna
360 Great Deals out of 26,682 listings starting at $1,950
Used Ford Explorer
934 Great Deals out of 68,717 listings starting at $1,800
Used Dodge Caravan
571 listings starting at $3,995
Used Ford Expedition
361 Great Deals out of 18,324 listings starting at $1,989
Used Ford Ranger
149 Great Deals out of 5,460 listings starting at $800
Used Chevrolet Venture
365 listings starting at $2,190

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.