Like to know

Asked by Mar 03, 2018 at 04:24 AM about the 1989 Chevrolet S-10 Blazer

Question type: General

Okay I have an 89 s10 Blazer with a 4.3. it
runs like a champ, but getting it started
seems to take a second or two. If the engine
is warmed up then it starts just fine. I was
told that this could be because of a bad 02
censor. But I'm not sure, so if anyone can
give me advice before I start throwing
money I don't have into this thing.

2 Answers

8,775

turn the key to run position and turn it off , then start it see if that makes a difference , it may not be getting primed to fire up ,

do you have a fuel pressure gauge?

Your Answer:

Chevrolet S-10 Blazer Experts

  • #1
    Cody Doud
    Reputation
    810
  • #2
    emtfirefighter77
    Reputation
    610
  • #3
    crazzy450r
    Reputation
    370
View All

Related Models For Sale

Used Chevrolet Blazer
595 listings starting at $1,879
Used Chevrolet S-10
10 Great Deals out of 785 listings starting at $1,850
Used GMC Jimmy
94 listings
Used Ford F-150
3,854 Great Deals out of 219,000 listings starting at $921
Used Ford Bronco
205 listings
Used Ford Ranger
140 Great Deals out of 4,541 listings starting at $1,400
Used Chevrolet C/K 1500
625 listings starting at $2,950
Used Chevrolet Camaro
756 Great Deals out of 29,100 listings starting at $2,499
Used Toyota 4Runner
403 Great Deals out of 26,751 listings starting at $1,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.