start engine put in on drive and not running. not moving;Put on 2nd gear or 1st will run


Asked by Mar 22, 2015 at 08:29 AM about the 1999 Nissan Cefiro

Question type: Maintenance & Repair

I start engine and put it on a drive position but it does not move at all or run.Put it on 1st
or 2nd Gear it run.
And sometimes it run on drive ..sometimes not.
Please I need help. I just bought this 3 weeks ago from a dealer.

2 Answers


Engine dies when you put the gearshift in drive? Many trans have electronics for position of manual lever. Used to be MLP sensor or equivalent. Many call them TR sensor now. An OBD II test can be run. You may need specific trans tests with japanese trans before year 2000. The computer could be a separate unit? You must call trans specialist or your dealer.

1 out of 1 people think this is helpful.

Put on Drive still engine running but does not move,Sir. Only move on reverse,1st and 2nd gear. Keep on doing all these and it will accidentally run in a DRIVE position. And that takes a lot of times trying. And the Drive gear still not working properly. Once I am running on that drive gear on the street no problem. Seems like running good and no problem. But every time I stopped and start it again it will do the same problem,.Sir. Thank you so much for your great help. I will try to get the mechanic to do ur suggestion, Fe Teresa

2 out of 2 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Nissan Cefiro Questions

Nissan Cefiro Experts

#1 Louie Varias
Louie Varias
Reputation 220
#2 Fling
Reputation 80
#3 jkintau
Reputation 60
View All