My car, a 2004 Dodge Stratus 2.4L DOHC, is losing power when I accelerate. The rpms go up but the car doesn't accelerate. The check engine light was on and the code reader said o2 sensor.

10

Asked by Sep 08, 2013 at 05:46 PM about the 2004 Dodge Stratus

Question type: Maintenance & Repair

We changed the upstream o2 sensor. The
light went off but the problem didn't stop.
Please help. Btw...the car has 211, 300
miles.

2 Answers

405

did you reset the computer afterwards?

1 of 1 people found this helpful.
10

We disconnected the battery then reconnected it.

1 of 1 people found this helpful.

Your Answer

Dodge Stratus Experts

  • #1
    Tom Demyan
    Reputation
    1,060
  • #2
    Chris Daigle
    Reputation
    650
  • #3
    curry22
    Reputation
    580
View All

Related Models For Sale

Used Chrysler Sebring
26 Great Deals out of 2,732 listings starting at $995
Used Ford Mustang
588 Great Deals out of 36,176 listings starting at $1,200
Used Chevrolet Impala
539 Great Deals out of 35,141 listings starting at $900
Used Nissan Altima
982 Great Deals out of 77,955 listings starting at $1,695
Used Honda Accord
984 Great Deals out of 59,478 listings starting at $1,099
Used Pontiac Grand Prix
31 Great Deals out of 2,644 listings starting at $1,449
Used Honda Civic
762 Great Deals out of 69,167 listings starting at $1,350
Used Ford Focus
777 Great Deals out of 55,466 listings starting at $800
Used Dodge Neon
577 listings starting at $999
Used Chevrolet Malibu
942 Great Deals out of 65,162 listings starting at $1,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.