85 c10

Asked by Jan 18, 2016 at 06:25 PM about the 1988 Chevrolet C/K 1500

Question type: General

I have an 85 C10 when I press the brake my front
yellow markers come on and my tail lights do not
flash (all lights are on).. I checked the fuse for my
blinkers and it works but my signal does not work
either. All lights come on and the back of the fuse
block seems to be connected right just not getting
a flash when I press the brake or signals. It's seems
like it's backwards any help is appreciated thank
you

2 Answers

100,335

Make sure the 4 way switch is completely off, you may have to run it in and out a few times just to make sure. If that didn't cure it then you need to check the sockets for broken contacts and grounds and possible cross circuits inside the lamps.

76,635

Has someone been screwing with your electrical system?

Your Answer

Chevrolet C/K 1500 Experts

  • #1
    Andrew Olsen
    Reputation
    3,600
  • #2
    John Saffrahn
    Reputation
    2,570
  • #3
    Rowefast
    Reputation
    2,170
View All

Related Models For Sale

Used GMC Sierra 1500
889 Great Deals out of 65,336 listings starting at $1,995
Used Ford F-150
2,320 Great Deals out of 182,094 listings starting at $1,000
Used Chevrolet C/K 2500
198 listings starting at $6,495
Used Chevrolet C/K 3500
229 listings starting at $4,999
Used Chevrolet Camaro
407 Great Deals out of 30,657 listings starting at $3,550
Used Chevrolet S-10
8 Great Deals out of 1,217 listings starting at $2,500

Used Cars For Sale

1998 Chevrolet C/K 1500 For Sale
162 listings starting at $2,000
1995 Chevrolet C/K 1500 For Sale
78 listings starting at $2,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.