85 c10

Asked by Jan 18, 2016 at 06:25 PM about the 1988 Chevrolet C/K 1500

Question type: General

I have an 85 C10 when I press the brake my front
yellow markers come on and my tail lights do not
flash (all lights are on).. I checked the fuse for my
blinkers and it works but my signal does not work
either. All lights come on and the back of the fuse
block seems to be connected right just not getting
a flash when I press the brake or signals. It's seems
like it's backwards any help is appreciated thank
you

2 Answers

86,905

Make sure the 4 way switch is completely off, you may have to run it in and out a few times just to make sure. If that didn't cure it then you need to check the sockets for broken contacts and grounds and possible cross circuits inside the lamps.

46,985

Has someone been screwing with your electrical system?

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 3,050
#2 John Saffrahn
John Saffrahn
Reputation 2,410
#3 Rowefast
Rowefast
Reputation 1,580
View All

Related Models For Sale

Used GMC Sierra 1500
938 Great Deals out of 62,274 listings starting at $1,395
Used Ford F-150
2,700 Great Deals out of 212,349 listings starting at $1,000
Used Chevrolet C/K 2500
238 listings starting at $2,900
Used Chevrolet C/K 10
272 listings starting at $19,900
Used Chevrolet C/K 3500
266 listings starting at $3,950
Used Chevrolet Camaro
279 Great Deals out of 38,301 listings starting at $1,250
Used Chevrolet S-10
10 Great Deals out of 1,656 listings starting at $2,450

Used Cars For Sale

1995 Chevrolet C/K 1500 For Sale
117 listings starting at $4,400