I have no power what so ever I had the alternator tested and it tested good so I bought a new battery worked fine until today it started sputtering and back firing than died now I have no power again

Asked by Apr 22, 2014 at 07:16 PM about the 1988 Chevrolet C/K 1500

Question type: Maintenance & Repair

1 Answer

110,975

Sounds like a loose connection or alternator is acting up and not keeping battery charged. I would check and clean all connections first. Also check the negative battery connections on the frame and motor. Have battery charged and it should start back up. If battery looses charge again I would start thinking alternator. I had an alternator that tested good but would not keep my battery charged. Replaced it and all is good now.

Your Answer

Add photo

Related Questions

Search Chevrolet C/K 1500 Questions

Chevrolet C/K 1500 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 3,410
#2 John Saffrahn
John Saffrahn
Reputation 2,530
#3 Rowefast
Rowefast
Reputation 2,100
View All

Related Models For Sale

Used GMC Sierra 1500
762 Great Deals out of 69,121 listings starting at $1,850
Used Ford F-150
2,064 Great Deals out of 207,332 listings starting at $1,499
Used Chevrolet C/K 2500
220 listings starting at $2,250
Used Chevrolet S-10
5 Great Deals out of 1,311 listings starting at $2,400
Used Chevrolet Camaro
242 Great Deals out of 31,193 listings starting at $369
Used Chevrolet C/K 3500
238 listings starting at $4,797

Used Cars For Sale

1998 Chevrolet C/K 1500 For Sale
165 listings starting at $3,290
1996 Chevrolet C/K 1500 For Sale
100 listings starting at $3,699
1995 Chevrolet C/K 1500 For Sale
95 listings starting at $4,800

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.